How to configure External BGP and EIGRP on DMVPN Phase 2?

 

 

The first DMVPN lesson explained the basics and I explained how to configure a basic DMVPN phase 2 network. I also explain how to configure the EIGRP phase 1 network and OSPF Phase 1 network

In this lesson, we’ll take a look at how we can use external BGP on DMVPN phase 2 networks and EIGRP. Here is the topology we will use:




R1(config)#interface serial 4/0

R1(config-if)#ip address 1.1.1.1 255.0.0.0

R1(config-if)#no shutdown


R1(config-if)#interface fastethernet 0/0

R1(config-if)#ip address 10.1.1.1 255.0.0.0

R1(config-if)#no shutdown

R1(config-if)#exit



R2(config)#interface serial 4/0

R2(config-if)#ip address 1.1.1.2 255.0.0.0

R2(config-if)#no shutdown


R2(config-if)#interface serial 4/1

R2(config-if)#ip address 3.3.3.1 255.0.0.0

R2(config-if)#no shutdown


R2(config-if)#interface serial 4/2

R2(config-if)#ip address 4.4.4.1 255.0.0.0

R2(config-if)#no shutdown


R2(config-if)#interface fastethernet 0/0

R2(config-if)#ip address 20.1.1.1 255.0.0.0

R2(config-if)#no shutdown

R2(config-if)#no keepalive

R2(config-if)#exit



R3(config)#interface serial 4/1

R3(config-if)#ip address 3.3.3.2 255.0.0.0

R3(config-if)#no shutdown


R3(config-if)#interface fastethernet 0/0

R3(config-if)#ip address 30.1.1.1 255.0.0.0

R3(config-if)#no shutdown

R3(config-if)#exit


R4(config)#interface serial 4/2

R4(config-if)#ip address 4.4.4.2 255.0.0.0

R4(config-if)#no shutdown


R4(config-if)#interface fastethernet 0/0

R4(config-if)#ip address 40.1.1.1 255.0.0.0

R4(config-if)#no shutdown

R4(config-if)#exit


R1(config)#ip route 0.0.0.0 0.0.0.0 serial 4/0

R1(config)#exit


R2(config)#ip route 1.0.0.0 255.0.0.0 serial 4/0

R2(config)#ip route 10.0.0.0 255.0.0.0 serial 4/0

R2(config)#ip route 30.0.0.0 255.0.0.0 serial 4/1

R2(config)#ip route 3.0.0.0 255.0.0.0 serial 4/1

R2(config)#ip route 4.0.0.0 255.0.0.0 serial 4/2

R2(config)#ip route 40.0.0.0 255.0.0.0 serial 4/2


R3(config)#ip route 0.0.0.0 0.0.0.0 serial 4/1

R3(config)#exit


R4(config)#ip route 0.0.0.0 0.0.0.0 serial 4/2

R4(config)#exit



R1#ping 40.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 40.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 24/45/88 ms

R1#ping 30.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 30.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/37/40 ms

R1#ping 20.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 20.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 16/20/36 ms


R1(config)#interface tunnel 4321

R1(config-if)#ip address 192.168.1.1 255.255.255.0

R1(config-if)#tunnel source 1.1.1.1

R1(config-if)#tunnel mode gre multipoint

*May 27 12:15:21.279: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel4321, changed state to up

 R1(config-if)#ip nhrp network-id 1

R1(config-if)#exit


R3(config)#interface tunnel 4321

R3(config-if)#ip address 192.168.1.2 255.255.255.0

R3(config-if)#tunnel source 3.3.3.2

R3(config-if)#tunnel mode gre multipoint

*May 27 12:19:21.451: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel4321, changed state to up

R3(config-if)#ip nhrp network-id 3

R3(config-if)# ip nhrp map 192.168.1.1 1.1.1.1

R3(config-if)#ip nhrp nhs 192.168.1.1

R3(config)#end


R4(config)#interface tunnel 4321

R4(config-if)#ip address 192.168.1.3 255.255.255.0

R4(config-if)#tunnel source 4.4.4.2

R4(config-if)#tunnel mode gre multipoint

*May 27 12:27:05.091: %LINEPROTO-5-UPDOWN: Line protocol on Interface Tunnel4321, changed state to up

R4(config-if)#ip nhrp network-id 4

R4(config-if)#ip nhrp map 192.168.1.1 1.1.1.1

R4(config-if)#ip nhrp nhs 192.168.1.1

R4(config-if)#exit

R4(config)#end


R1(config)#router eigrp 4321

R1(config-router)#network 192.168.1.0

R1(config-router)#network 10.0.0.0

R1(config-router)#no auto-summary

R1(config-router)#exit


R3(config)#router eigrp 4321

R3(config-router)#network 192.168.1.0

R3(config-router)#network 10.0.0.0

R3(config-router)#no auto-summary

R3(config-router)#exit


R4(config)#router eigrp 4321

R4(config-router)#network 192.168.1.0

R4(config-router)#network 40.0.0.0

R4(config-router)#no auto-summary

R4(config-router)#exit


R1(config)#interface tunnel 4321

R1(config-if)#ip nhrp map multicast dynamic

R1(config-if)#exit


R1(config)#interface tunnel 4321

R1(config-if)#no ip split-horizon eigrp 4321

R1(config-if)#exit


R1(config)#interface tunnel 4321

R1(config-if)#no ip next-hop-self eigrp 4321


*May 27 12:51:44.351: %DUAL-5-NBRCHANGE: EIGRP-IPv4 4321: Neighbor 192.168.1.2 (Tunnel4321) is up: new adjacency

*May 27 12:52:53.611: %DUAL-5-NBRCHANGE: EIGRP-IPv4 4321: Neighbor 192.168.1.3 (Tunnel4321) is up: new adjacency

R1(config-if)#end


R3(config)#interface tunnel 4321

R3(config-if)#ip nhrp map multicast 1.1.1.1

R3(config-if)#ip nhrp map multicast 4.4.4.2

*May 27 12:52:05.019: %DUAL-5-NBRCHANGE: EIGRP-IPv4 4321: Neighbor 192.168.1.3 (Tunnel4321) is up: new adjacency

R3(config-if)#end


R4(config)#interface tunnel 4321

R4(config-if)#ip nhrp map multicast 3.3.3.2

R4(config-if)#ip nhrp map multicast 1.1.1.1

R4(config-if)#exit

{( if you get any error msg please shutdown physical interfaces and tunnel interface and restart the interfaces) Command SHUTDOWN and NO SHUTDOWN}


R4#show DMVPN

Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete

        N - NATed, L - Local, X - No Socket

        # Ent --> Number of NHRP entries with same NBMA peer

        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting

        UpDn Time --> Up or Down Time for a Tunnel

==========================================================================

 

Interface: Tunnel4321, IPv4 NHRP Details

Type:Spoke, NHRP Peers:2,

 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb

 ----- --------------- --------------- ----- -------- -----

     1 1.1.1.1             192.168.1.1    UP 00:15:50     S

     1 3.3.3.2             192.168.1.2    UP 00:15:30     D

 

R4#show IP NHRP

192.168.1.1/32 via 192.168.1.1

   Tunnel4321 created 00:16:09, never expire

   Type: static, Flags: used

   NBMA address: 1.1.1.1

192.168.1.2/32 via 192.168.1.2

   Tunnel4321 created 00:15:41, expire 01:44:18

   Type: dynamic, Flags: router used

   NBMA address: 3.3.3.2

192.168.1.3/32 via 192.168.1.3

   Tunnel4321 created 00:15:41, expire 01:44:18

   Type: dynamic, Flags: router unique local

   NBMA address: 4.4.4.2

    (no-socket)


R4(config-if)#do show ip route eigrp 

Gateway of last resort is 0.0.0.0 to network 0.0.0.0

 

D     10.0.0.0/8 [90/26882560] via 192.168.1.1, 00:00:54, Tunnel4321

D     30.0.0.0/8 [90/26882560] via 192.168.1.2, 00:00:32, Tunnel4321

R4(config-if)#end



R4#ping 10.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/40/44 ms

R4#ping 30.1.1.1

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 30.1.1.1, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 12/21/40 ms


 

R4#traceroute 10.1.1.1

Type escape sequence to abort.

Tracing the route to 10.1.1.1

VRF info: (vrf in name/id, vrf out name/id)

  1 192.168.1.1 56 msec 64 msec 20 msec


R4#traceroute 30.1.1.1

Type escape sequence to abort.

Tracing the route to 30.1.1.1

VRF info: (vrf in name/id, vrf out name/id)

  1 192.168.1.2 20 msec 36 msec 32 msec


R1#traceroute 30.1.1.1

Type escape sequence to abort.

Tracing the route to 30.1.1.1

VRF info: (vrf in name/id, vrf out name/id)

  1 192.168.1.2 20 msec 48 msec 28 msec

R1#traceroute 40.1.1.1

Type escape sequence to abort.

Tracing the route to 40.1.1.1

VRF info: (vrf in name/id, vrf out name/id)

  1 192.168.1.3 20 msec 24 msec 44 msec


R3#show dmvpn

Legend: Attrb --> S - Static, D - Dynamic, I - Incomplete

        N - NATed, L - Local, X - No Socket

        # Ent --> Number of NHRP entries with same NBMA peer

        NHS Status: E --> Expecting Replies, R --> Responding, W --> Waiting

        UpDn Time --> Up or Down Time for a Tunnel

==========================================================================

 

Interface: Tunnel4321, IPv4 NHRP Details

Type:Spoke, NHRP Peers:2,

 

 # Ent  Peer NBMA Addr Peer Tunnel Add State  UpDn Tm Attrb

 ----- --------------- --------------- ----- -------- -----

     1 1.1.1.1             192.168.1.1    UP 00:09:29     S

     1 4.4.4.2             192.168.1.3    UP 00:00:58     D


 

 R3#traceroute 10.1.1.1

Type escape sequence to abort.

Tracing the route to 10.1.1.1

VRF info: (vrf in name/id, vrf out name/id)

  1 192.168.1.1 16 msec 36 msec 16 msec


R3#traceroute 40.1.1.1

Type escape sequence to abort.

Tracing the route to 40.1.1.1

VRF info: (vrf in name/id, vrf out name/id)

  1 192.168.1.3 12 msec 48 msec 40 msec


 now modify our current lab with EBGP. Remove EIGRP and configure EBGP.

Topology :-



R1(config)#no router eigrp 4321

R1(config)#do show ip pro

*** IP Routing is NSF aware ***


R3(config)#no router eigrp 4321

R4(config)#no router eigrp 4321

*May 27 13:24:43.167: %DUAL-5-NBRCHANGE: EIGRP-IPv4 4321: Neighbor 192.168.1.1 (Tunnel4321) is down: Interface PEER-TERMINATION received

*May 27 13:25:19.707: %DUAL-5-NBRCHANGE: EIGRP-IPv4 4321: Neighbor 192.168.1.2 (Tunnel4321) is down: Interface PEER-TERMINATION received

R1(config)#router bgp 1234

R1(config-router)#neighbor 192.168.1.2 remote-as 3421

R1(config-router)#neighbor 192.168.1.3 remote-as 4321

R1(config-router)#network 10.0.0.0 mask 255.0.0.0

R1(config-router)#exit


R3(config)#router bgp 3421

R3(config-router)#neighbor 192.168.1.1 remote-as 1234

*May 27 13:40:11.415: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Up

R3(config-router)#neighbor 192.168.1.3 remote-as 4321

R3(config-router)#network 30.0.0.0 mask 255.0.0.0

R3(config-router)#exit


R4(config)#router bgp 4321

R4(config-router)#neighbor 192.168.1.1 remote-as 1234

*May 27 13:41:37.855: %BGP-5-ADJCHANGE: neighbor 192.168.1.1 Up

R4(config-router)#neighbor 192.168.1.2 remote-as 3421

*May 27 13:41:57.815: %BGP-5-ADJCHANGE: neighbor 192.168.1.2 Up

R4(config-router)#network 40.0.0.0 mask 255.0.0.0

R4(config-router)#exit

R4(config)#end



R1#show bgp

BGP table version is 4, local router ID is 192.168.1.1

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

     Network          Next Hop            Metric LocPrf Weight Path

 *>  10.0.0.0         0.0.0.0                  0         32768 i

 *   30.0.0.0         192.168.1.2                            0 4321 3421 i

 *>                   192.168.1.2              0             0 3421 i

 *   40.0.0.0         192.168.1.3                            0 3421 4321 i

 *>                   192.168.1.3              0             0 4321 i

R1#show ip bgp summary

BGP router identifier 192.168.1.1, local AS number 1234

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

192.168.1.2     4         3421       8       9        4    0    0 00:03:45        2

192.168.1.3     4         4321       7      10        4    0    0 00:01:59        2


R3#show bgp

BGP table version is 4, local router ID is 192.168.1.2

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

     Network          Next Hop            Metric LocPrf Weight Path

 *   10.0.0.0         192.168.1.1                            0 4321 1234 i

 *>                   192.168.1.1              0             0 1234 i

 *>  30.0.0.0         0.0.0.0                  0         32768 i

 *   40.0.0.0         192.168.1.3                            0 1234 4321 i

 *>                   192.168.1.3              0             0 4321 i


R3#show ip bgp summary

BGP router identifier 192.168.1.2, local AS number 3421

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

192.168.1.1     4         1234       8       8        4    0    0 00:03:32        2

192.168.1.3     4         4321      10       9        4    0    0 00:01:25        2


R4#show bgp

BGP table version is 5, local router ID is 192.168.1.3

Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,

              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,

              x best-external, a additional-path, c RIB-compressed,

Origin codes: i - IGP, e - EGP, ? - incomplete

RPKI validation codes: V valid, I invalid, N Not found

 

     Network          Next Hop            Metric LocPrf Weight Path

 *   10.0.0.0         192.168.1.1                            0 3421 1234 i

 *>                   192.168.1.1              0             0 1234 i

 *>  30.0.0.0         192.168.1.2              0             0 3421 i

 *                    192.168.1.2                            0 1234 3421 i

 *>  40.0.0.0         0.0.0.0                  0         32768 i


R4#show ip bgp summary

BGP router identifier 192.168.1.3, local AS number 4321

 

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd

192.168.1.1     4         1234       9       6        5    0    0 00:01:24        2

192.168.1.2     4         3421       9      10        5    0    0 00:01:04        2



Internetworks

Author & Editor

I am CCIE Technical Instructor/Network consultant. i am having experience of ranging from operating and maintaining PCs and peripherals to network control programs for multi-faceted data communication networks in LAN,MAN, and WAN environments.

0 comments: