What is MPLS Label distributing protocol (LDP) ? How LDP works?

Label distributing protocol (LDP) is a protocol which is automatically generates and exchanges labels between MPLS routers. Each MPLS router will locally generate labels for its prefixes and then it will advertise the label values to its neighbors.…



Label distributing protocol (LDP) is a protocol which is automatically generates and exchanges labels between MPLS routers. Each MPLS router will locally generate labels for its prefixes and then it will advertise the label values to its neighbors.

Label distributing protocol (LDP) Work with IGP inside the core. It’s a standard protocol; LDP is based on Cisco’s proprietary Tag Distribution Protocol (TDP). LDP establish a neighbor relationship using UDP (port 646) hellos multicast packets are sent 224.0.0.2. Each router has a unique router ID called LSR ID.  

How Label distributing protocol (LDP works?
  1. IGP built routing table (fib using CEF)
  2. LSR assign a local label for each route learned
  3. LSR share labels with neighbor using LDP
  4. LSR built their own LFIB
  5. Forward packets based on label lookup


1. Introduction of MPLS

2.What is MPLS Label distributing protocol (LDP) ? How LDP works?

3.how to configure MPLS LDP Peering ?

4.What is MPLS L3 VPN ? How to configure?

5.How to configure MPLS L3 VPN with RIPv2 ?

6.How to configure MPLS L3 VPN with EIGRP ?

7.How to configure MPLS L3 VPN with OSPF ?

8.What is OSPF Sham Links? how to configure OSPF Sham Links?



 lets see the configuration:-

Topology:


Goal:
  • configure the topology as per the diagram.
  • assign IP address to their receptive interfaces 
  • configure EIGRP 100 and advertise directly connected interfaces 
  • configure MPLS on all the routers with LDP protocol.
  • configure LDP router ID has to be loop-back address 0
  • configure labels.
  • check the connectivity with trace route between router 1 and router 4. 



R1(config)#Interface fastethernet 0/0
R1(config-if)#Ip address 10.1.1.1   255.0.0.0
R1(config-if)#No shutdown
R1(config-if)#No keepalive
R1(config-if)#Exit

R1(config)#Interface serial 3/0
R1(config-if)#Ip address  1.1.1.1 255.0.0.0
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface loopback 0
R1(config-if)#Ip address 11.0.0.1 255.255.255.0
R1(config-if)#Exit

R1(config)#Interface loopback  1
R1(config-if)#Ip address 11.0.1.1 255.255.255.0
R1(config-if)#Exit

R1(config)#Interface loopback  2
R1(config-if)#Ip address 11.0.2.1 255.255.255.0
R1(config-if)#Exit

R1(config)#Interface loopback 3
R1(config-if)#Ip address 11.0.3.1 255.255.255.0
R1(config-if)#Exit




R2(config)#Interface fastethernet 0/0
R2(config-if)#Ip address 20.1.1.1   255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#No keepalive
R2(config-if)#Exit

R2(config)#Interface serial 3/0
R2(config-if)#Ip address  1.1.1.2 255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/1
R2(config-if)#Ip address  2.2.2.1 255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface loopback  1
R2(config-if)#Ip address 12.0.1.1 255.255.255.0
R2(config-if)#Exit

R2(config)#Interface loopback  2
R2(config-if)#Ip address 12.0.2.1 255.255.255.0
R2(config-if)#Exit

R2(config)#Interface loopback 3
R2(config-if)#Ip address 12.0.3.1 255.255.255.0
R2(config-if)#Exit




R3(config)#Interface fastethernet 0/0
R3(config-if)#Ip address 30.1.1.1   255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#No keepalive
R3(config-if)#Exit

R3(config)#Interface serial 3/1
R3(config-if)#Ip address  2.2.2.2 255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#Exit

R3(config)#Interface serial 3/2
R3(config-if)#Ip address  3.3.3.1 255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#Exit


R3(config)#Interface loopback 0
R3(config-if)#Ip address 13.0.0.1 255.255.255.0
R3(config-if)#Exit

R3(config)#Interface loopback  1
R3(config-if)#Ip address 13.0.1.1 255.255.255.0
R3(config-if)#Exit

R3(config)#Interface loopback  2
R3(config-if)#Ip address 13.0.2.1 255.255.255.0
R3(config-if)#Exit

R3(config)#Interface loopback 3
R3(config-if)#Ip address 13.0.3.1 255.255.255.0
R3(config-if)#exit



R4(config)#Interface fastethernet 0/0
R4(config-if)#Ip address 40.1.1.1   255.0.0.0
R4(config-if)#No shutdown
R4(config-if)#No keepalive
R4(config-if)#Exit

R4(config)#Interface serial 3/2
R4(config-if)#Ip address  3.3.3.2 255.0.0.0
R4(config-if)#No shutdown
R4(config-if)#Exit

R4(config)#Interface loopback 0
R4(config-if)#Ip address 14.0.0.1 255.255.255.0
R4(config-if)#Exit

R4(config)#Interface loopback  1
R4(config-if)#Ip address 14.0.1.1 255.255.255.0
R4(config-if)#Exit

R4(config)#Interface loopback  2
R4(config-if)#Ip address 14.0.2.1 255.255.255.0
R4(config-if)#Exit

R4(config)#Interface loopback 3
R4(config-if)#Ip address 14.0.3.1 255.255.255.0
R4(config-if)#Exit


R1(config)#router eigrp 100
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#network 11.0.0.0
R1(config-router)#no auto-summary
R1(config-router)#exit

*Jan  9 23:58:37.835: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.1.1.2 (Serial3/0) is up: new adjacency

R2(config)#router eigrp 100
R2(config-router)#network 2.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 1.0.0.0
R2(config-router)#network 12.0.0.0
R2(config-router)#no auto-summary
R2(config-router)#exit

*Jan 10 00:16:23.063: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.2.2.2 (Serial3/1) is up: new adjacency

*Jan 10 00:16:32.295: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.1.1.1 (Serial3/0) is up: new adjacency

R3(config)#router eigrp 100
R3(config-router)#network 2.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#network 13.0.0.0
R3(config-router)#exit

*Jan 10 00:02:30.555: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.2.2.1 (Serial3/1) is up: new adjacency

*Jan 10 00:03:32.187: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 3.3.3.2 (Serial3/2) is up: new adjacency

R4(config)#router eigrp 100
R4(config-router)#network 3.0.0.0
R4(config-router)#network 40.0.0.0
R4(config-router)#network 14.0.0.0
R4(config-router)#no auto-summary
R4(config-router)#exit

*Jan 10 00:03:22.463: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 3.3.3.1 (Serial3/2) is up: new adjacency


R1#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override


Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.1/32 is directly connected, Serial3/0
D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 00:03:36, Serial3/0
D     3.0.0.0/8 [90/3193856] via 1.1.1.2, 00:03:36, Serial3/0
      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, FastEthernet0/0
L        10.1.1.1/32 is directly connected, FastEthernet0/0
      11.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C        11.0.0.0/24 is directly connected, Loopback0
L        11.0.0.1/32 is directly connected, Loopback0
C        11.0.1.0/24 is directly connected, Loopback1
L        11.0.1.1/32 is directly connected, Loopback1
C        11.0.2.0/24 is directly connected, Loopback2
L        11.0.2.1/32 is directly connected, Loopback2
C        11.0.3.0/24 is directly connected, Loopback3
L        11.0.3.1/32 is directly connected, Loopback3
      12.0.0.0/24 is subnetted, 3 subnets
D        12.0.1.0 [90/2297856] via 1.1.1.2, 00:03:36, Serial3/0
D        12.0.2.0 [90/2297856] via 1.1.1.2, 00:03:36, Serial3/0
D        12.0.3.0 [90/2297856] via 1.1.1.2, 00:03:36, Serial3/0
      13.0.0.0/24 is subnetted, 4 subnets
D        13.0.0.0 [90/2809856] via 1.1.1.2, 00:03:36, Serial3/0
D        13.0.1.0 [90/2809856] via 1.1.1.2, 00:03:36, Serial3/0
D        13.0.2.0 [90/2809856] via 1.1.1.2, 00:03:36, Serial3/0
D        13.0.3.0 [90/2809856] via 1.1.1.2, 00:03:36, Serial3/0
      14.0.0.0/24 is subnetted, 4 subnets
D        14.0.0.0 [90/3321856] via 1.1.1.2, 00:03:36, Serial3/0
D        14.0.1.0 [90/3321856] via 1.1.1.2, 00:03:36, Serial3/0
D        14.0.2.0 [90/3321856] via 1.1.1.2, 00:03:36, Serial3/0
D        14.0.3.0 [90/3321856] via 1.1.1.2, 00:03:36, Serial3/0
D     20.0.0.0/8 [90/2172416] via 1.1.1.2, 00:03:36, Serial3/0
D     30.0.0.0/8 [90/2684416] via 1.1.1.2, 00:03:36, Serial3/0
D     40.0.0.0/8 [90/3196416] via 1.1.1.2, 00:00:38, Serial3/0

  


R2#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      1.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        1.0.0.0/8 is directly connected, Serial3/0
L        1.1.1.2/32 is directly connected, Serial3/0
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, Serial3/1
L        2.2.2.1/32 is directly connected, Serial3/1
D     3.0.0.0/8 [90/2681856] via 2.2.2.2, 00:11:40, Serial3/1
D     10.0.0.0/8 [90/2172416] via 1.1.1.1, 00:01:08, Serial3/0
      11.0.0.0/24 is subnetted, 4 subnets
D        11.0.0.0 [90/2297856] via 1.1.1.1, 00:04:25, Serial3/0
D        11.0.1.0 [90/2297856] via 1.1.1.1, 00:04:24, Serial3/0
D        11.0.2.0 [90/2297856] via 1.1.1.1, 00:04:24, Serial3/0
D        11.0.3.0 [90/2297856] via 1.1.1.1, 00:04:24, Serial3/0
      12.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
C        12.0.1.0/24 is directly connected, Loopback1
L        12.0.1.1/32 is directly connected, Loopback1
C        12.0.2.0/24 is directly connected, Loopback2
L        12.0.2.1/32 is directly connected, Loopback2
C        12.0.3.0/24 is directly connected, Loopback3
L        12.0.3.1/32 is directly connected, Loopback3
      13.0.0.0/24 is subnetted, 4 subnets
D        13.0.0.0 [90/2297856] via 2.2.2.2, 00:11:40, Serial3/1
D        13.0.1.0 [90/2297856] via 2.2.2.2, 00:11:40, Serial3/1
D        13.0.2.0 [90/2297856] via 2.2.2.2, 00:11:40, Serial3/1
D        13.0.3.0 [90/2297856] via 2.2.2.2, 00:11:40, Serial3/1
      14.0.0.0/24 is subnetted, 4 subnets
D        14.0.0.0 [90/2809856] via 2.2.2.2, 00:10:29, Serial3/1
D        14.0.1.0 [90/2809856] via 2.2.2.2, 00:10:29, Serial3/1
D        14.0.2.0 [90/2809856] via 2.2.2.2, 00:10:29, Serial3/1
D        14.0.3.0 [90/2809856] via 2.2.2.2, 00:10:29, Serial3/1
      20.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        20.0.0.0/8 is directly connected, FastEthernet0/0
L        20.1.1.1/32 is directly connected, FastEthernet0/0
D     30.0.0.0/8 [90/2172416] via 2.2.2.2, 00:11:40, Serial3/1
D     40.0.0.0/8 [90/2684416] via 2.2.2.2, 00:10:34, Serial3/1




R3#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override


Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 2.2.2.1, 00:11:39, Serial3/1
      2.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        2.0.0.0/8 is directly connected, Serial3/1
L        2.2.2.2/32 is directly connected, Serial3/1
      3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        3.0.0.0/8 is directly connected, Serial3/2
L        3.3.3.1/32 is directly connected, Serial3/2
D     10.0.0.0/8 [90/2684416] via 2.2.2.1, 00:01:16, Serial3/1
      11.0.0.0/24 is subnetted, 4 subnets
D        11.0.0.0 [90/2809856] via 2.2.2.1, 00:04:33, Serial3/1
D        11.0.1.0 [90/2809856] via 2.2.2.1, 00:04:33, Serial3/1
D        11.0.2.0 [90/2809856] via 2.2.2.1, 00:04:32, Serial3/1
D        11.0.3.0 [90/2809856] via 2.2.2.1, 00:04:32, Serial3/1
      12.0.0.0/24 is subnetted, 3 subnets
D        12.0.1.0 [90/2297856] via 2.2.2.1, 00:11:34, Serial3/1
D        12.0.2.0 [90/2297856] via 2.2.2.1, 00:11:34, Serial3/1
D        12.0.3.0 [90/2297856] via 2.2.2.1, 00:11:34, Serial3/1
      13.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C        13.0.0.0/24 is directly connected, Loopback0
L        13.0.0.1/32 is directly connected, Loopback0
C        13.0.1.0/24 is directly connected, Loopback1
L        13.0.1.1/32 is directly connected, Loopback1
C        13.0.2.0/24 is directly connected, Loopback2
L        13.0.2.1/32 is directly connected, Loopback2
C        13.0.3.0/24 is directly connected, Loopback3
L        13.0.3.1/32 is directly connected, Loopback3
      14.0.0.0/24 is subnetted, 4 subnets
D        14.0.0.0 [90/2297856] via 3.3.3.2, 00:10:37, Serial3/2
D        14.0.1.0 [90/2297856] via 3.3.3.2, 00:10:37, Serial3/2
D        14.0.2.0 [90/2297856] via 3.3.3.2, 00:10:37, Serial3/2
D        14.0.3.0 [90/2297856] via 3.3.3.2, 00:10:37, Serial3/2
D     20.0.0.0/8 [90/2172416] via 2.2.2.1, 00:11:44, Serial3/1
      30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        30.0.0.0/8 is directly connected, FastEthernet0/0
L        30.1.1.1/32 is directly connected, FastEthernet0/0
D     40.0.0.0/8 [90/2172416] via 3.3.3.2, 00:10:42, Serial3/2


R4#show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set


D     1.0.0.0/8 [90/3193856] via 3.3.3.1, 00:10:20, Serial3/2
D     2.0.0.0/8 [90/2681856] via 3.3.3.1, 00:10:20, Serial3/2
      3.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        3.0.0.0/8 is directly connected, Serial3/2
L        3.3.3.2/32 is directly connected, Serial3/2
D     10.0.0.0/8 [90/3196416] via 3.3.3.1, 00:00:50, Serial3/2
      11.0.0.0/24 is subnetted, 4 subnets
D        11.0.0.0 [90/3321856] via 3.3.3.1, 00:04:06, Serial3/2
D        11.0.1.0 [90/3321856] via 3.3.3.1, 00:04:06, Serial3/2
D        11.0.2.0 [90/3321856] via 3.3.3.1, 00:04:06, Serial3/2
D        11.0.3.0 [90/3321856] via 3.3.3.1, 00:04:06, Serial3/2
      12.0.0.0/24 is subnetted, 3 subnets
D        12.0.1.0 [90/2809856] via 3.3.3.1, 00:10:20, Serial3/2
D        12.0.2.0 [90/2809856] via 3.3.3.1, 00:10:20, Serial3/2
D        12.0.3.0 [90/2809856] via 3.3.3.1, 00:10:20, Serial3/2
      13.0.0.0/24 is subnetted, 4 subnets
D        13.0.0.0 [90/2297856] via 3.3.3.1, 00:10:20, Serial3/2
D        13.0.1.0 [90/2297856] via 3.3.3.1, 00:10:20, Serial3/2
D        13.0.2.0 [90/2297856] via 3.3.3.1, 00:10:20, Serial3/2
D        13.0.3.0 [90/2297856] via 3.3.3.1, 00:10:20, Serial3/2
      14.0.0.0/8 is variably subnetted, 8 subnets, 2 masks
C        14.0.0.0/24 is directly connected, Loopback0
L        14.0.0.1/32 is directly connected, Loopback0
C        14.0.1.0/24 is directly connected, Loopback1
L        14.0.1.1/32 is directly connected, Loopback1
C        14.0.2.0/24 is directly connected, Loopback2
L        14.0.2.1/32 is directly connected, Loopback2
C        14.0.3.0/24 is directly connected, Loopback3
L        14.0.3.1/32 is directly connected, Loopback3
D     20.0.0.0/8 [90/2684416] via 3.3.3.1, 00:10:20, Serial3/2
D     30.0.0.0/8 [90/2172416] via 3.3.3.1, 00:10:20, Serial3/2
      40.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        40.0.0.0/8 is directly connected, FastEthernet0/0
L        40.1.1.1/32 is directly connected, FastEthernet0/0

R1(config)#mpls label range 99 199
R1(config)#mpls label protocol ldp
R1(config)#mpls ldp router-id loopback 0

R1(config)#interface serial3/0
R1(config-if)#mpls ip
R1(config-if)#exit

*Jan 10 00:24:38.655: %LDP-5-NBRCHG: LDP Neighbor 12.0.1.1:0 (1) is UP

R2(config)#mpls label range 200 299
R2(config)#mpls label protocol ldp
R2(config)#mpls ldp router-id loopback 0

R2(config)#interface serial 3/0
R2(config-if)#mpls ip
R2(config-if)#exit

*Jan 10 00:36:03.895: %LDP-5-NBRCHG: LDP Neighbor 11.0.0.1:0 (1) is UP

R2(config)#interface serial 3/1
R2(config-if)#mpls ip
R2(config-if)#exit

*Jan 10 00:37:52.651: %LDP-5-NBRCHG: LDP Neighbor 13.0.0.1:0 (2) is UP

R3(config)#mpls label range 300 399
R3(config)#mpls label protocol ldp
R3(config)#mpls ldp router-id loopback 0

R3(config)#interface serial 3/1
R3(config-if)#mpls ip
R3(config-if)#exit


*Jan 10 00:24:00.095: %LDP-5-NBRCHG: LDP Neighbor 12.0.1.1:0 (1) is UP

R3(config)#interface serial 3/2
R3(config-if)#mpls ip
R3(config-if)#exit

*Jan 10 00:27:00.071: %LDP-5-NBRCHG: LDP Neighbor 14.0.0.1:0 (2) is UP

R4(config)#mpls label range 400 499
R4(config)#mpls label protocol ldp
R4(config)#mpls ldp router-id loopback 0

R4(config)#interface serial 3/2
R4(config-if)#mpls ip
R4(config-if)#exit

*Jan 10 00:26:50.247: %LDP-5-NBRCHG: LDP Neighbor 13.0.0.1:0 (1) is UP

R2#show mpls ldp neighbor
    Peer LDP Ident: 11.0.0.1:0; Local LDP Ident 12.0.1.1:0
        TCP connection: 11.0.0.1.646 - 12.0.1.1.26752
        State: Oper; Msgs sent/rcvd: 36/36; Downstream
        Up time: 00:10:02
        LDP discovery sources:
          Serial3/0, Src IP addr: 1.1.1.1
        Addresses bound to peer LDP Ident:
          10.1.1.1        1.1.1.1         11.0.0.1        11.0.1.1
          11.0.2.1        11.0.3.1
    Peer LDP Ident: 13.0.0.1:0; Local LDP Ident 12.0.1.1:0
        TCP connection: 13.0.0.1.39554 - 12.0.1.1.646
        State: Oper; Msgs sent/rcvd: 34/34; Downstream
        Up time: 00:08:13
        LDP discovery sources:
          Serial3/1, Src IP addr: 2.2.2.2
        Addresses bound to peer LDP Ident:
          30.1.1.1        2.2.2.2         3.3.3.1         13.0.0.1
          13.0.1.1        13.0.2.1        13.0.3.1




R3#show mpls ldp neighbor
    Peer LDP Ident: 12.0.1.1:0; Local LDP Ident 13.0.0.1:0
        TCP connection: 12.0.1.1.646 - 13.0.0.1.39554
        State: Oper; Msgs sent/rcvd: 33/33; Downstream
        Up time: 00:07:41
        LDP discovery sources:
          Serial3/1, Src IP addr: 2.2.2.1
        Addresses bound to peer LDP Ident:
          20.1.1.1        1.1.1.2         2.2.2.1         12.0.1.1
          12.0.2.1        12.0.3.1
    Peer LDP Ident: 14.0.0.1:0; Local LDP Ident 13.0.0.1:0
        TCP connection: 14.0.0.1.20440 - 13.0.0.1.646
        State: Oper; Msgs sent/rcvd: 30/30; Downstream
        Up time: 00:04:41
        LDP discovery sources:
          Serial3/2, Src IP addr: 3.3.3.2
        Addresses bound to peer LDP Ident:
          40.1.1.1        3.3.3.2         14.0.0.1        14.0.1.1
          14.0.2.1        14.0.3.1

R3#show mpls interfaces
Interface              IP            Tunnel   BGP Static Operational
Serial3/1              Yes (ldp)     No       No  No     Yes
Serial3/2              Yes (ldp)     No       No  No     Yes


R1#show mpls ldp bindings 40.0.0.0 255.0.0.0
  lib entry: 40.0.0.0/8, rev 44
        local binding:  label: 114
        remote binding: lsr: 12.0.1.1:0, label: 215


R1#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
99         Pop Label  2.0.0.0/8        0             Se3/0      point2point
100        200        3.0.0.0/8        0             Se3/0      point2point
101        Pop Label  12.0.1.0/24      0             Se3/0      point2point
102        Pop Label  12.0.2.0/24      0             Se3/0      point2point
103        Pop Label  12.0.3.0/24      0             Se3/0      point2point
104        206        13.0.0.0/24      0             Se3/0      point2point
105        207        13.0.1.0/24      0             Se3/0      point2point
106        208        13.0.2.0/24      0             Se3/0      point2point
107        209        13.0.3.0/24      0             Se3/0      point2point
108        210        14.0.0.0/24      0             Se3/0      point2point
109        211        14.0.1.0/24      0             Se3/0      point2point
110        212        14.0.2.0/24      0             Se3/0      point2point
111        213        14.0.3.0/24      0             Se3/0      point2point
112        Pop Label  20.0.0.0/8       0             Se3/0      point2point
113        214        30.0.0.0/8       0             Se3/0      point2point
114        215        40.0.0.0/8       0             Se3/0      point2point


R1#show mpls forwarding-table 40.1.1.1
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
114        215        40.0.0.0/8       0             Se3/0      point2point


R1#traceroute 40.1.1.1 source 10.1.1.1
Type escape sequence to abort.
Tracing the route to 40.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.2 [MPLS: Label 215 Exp 0] 116 msec 48 msec 80 msec
  2 2.2.2.2 [MPLS: Label 314 Exp 0] 44 msec 28 msec 56 msec
  3 3.3.3.2 44 msec 44 msec 68 msec



R4#traceroute 11.0.0.1 source 14.0.0.1
Type escape sequence to abort.
Tracing the route to 11.0.0.1
VRF info: (vrf in name/id, vrf out name/id)
  1 3.3.3.1 [MPLS: Label 302 Exp 0] 160 msec 116 msec 196 msec
  2 2.2.2.1 [MPLS: Label 202 Exp 0] 128 msec 112 msec 128 msec
  3 1.1.1.1 208 msec 120 msec 180 msec

Internetworks

Author & Editor

I am CCIE Technical Instructor/Network consultant. i am having experience of ranging from operating and maintaining PCs and peripherals to network control programs for multi-faceted data communication networks in LAN,MAN, and WAN environments.

0 comments: