How to configure MPLS L3 VPN with RIPv2 ?



In MPLS Layer 3 the service provider will participate in routing with the customers. The customers will run static, OSPF, EIGRP, BGP or any other routing protocol with the service provider; these routes can be shared with other sites of the customers.


In VPN routing information from one customer is completely separated from other customers and tunneled over the service provider MPLS network.



we have already discus what is MPLS? how MPLS work? and What is MPLS L3 VPN ? in this section we see how to configure MPLS L3 VPN supports RIPv2. Before we start our configuration you must familiar with these topics.




1. Introduction of MPLS

2.What is MPLS Label distributing protocol (LDP) ? How LDP works?

3.how to configure MPLS LDP Peering ?

4.What is MPLS L3 VPN ? How to configure?

5.How to configure MPLS L3 VPN with RIPv2 ?

6.How to configure MPLS L3 VPN with EIGRP ?

7.How to configure MPLS L3 VPN with OSPF ?

8.What is OSPF Sham Links? how to configure OSPF Sham Links?


Let see the configuration to get better understanding:-

Topology:




Goal:

  • configure the topology as per the diagram 
  • assign the IP addresses to their interfaces
  • configure IGP (EIGRP 65100) inside MPLS SP core 
  • configure MPLS LDP on router 1_2_3 
  • configure labels (99-199_200-299_300-399)
  • configure VRF a-1 on router 1 and VRF a-2 on router 3
  • configure RD and RT  value 100:1 on both the sites
  • configure on router 1 assign fastethernet facing CE under VRF a-1
  • configure on router 3 assign fastethernet facing CE under VRF a-2
  • configure RIPv2 on both CE routers  
  • make sure PE and CE routers can ping 
  • configure VPNv4 between PE routers. 
  • redistribute RIPv2 routing in to BGP under VRF
  • make sure CEs routers able to ping 







R1(config)#Interface fastethernet 0/0
R1(config-if)#Ip address 10.1.1.1   255.0.0.0
R1(config-if)#No shutdown
R1(config-if)# keepalive
R1(config-if)#Exit

R1(config)#Interface serial 3/0
R1(config-if)#Ip address  1.1.1.1 255.0.0.0
R1(config-if)#No shutdown
R1(config-if)#Exit




R1(config)#Interface serial 3/2
R1(config-if)#Ip address  3.3.3.2 255.0.0.0
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface loopback 0
R1(config-if)#Ip address 192.168.10.1 255.255.255.0
R1(config-if)#Exit

R1(config)#Interface loopback  1
R1(config-if)#Ip address 192.168.11.1 255.255.255.0
R1(config-if)#Exit
R1(config)#Interface loopback  2
R1(config-if)#Ip address 192.168.12.1 255.255.255.0
R1(config-if)#Exit
R1(config)#Interface loopback 3
R1(config-if)#Ip address 192.168.13.1  255.255.255.0
R1(config-if)#Exit








R2(config)#Interface fastethernet 0/0
R2(config-if)#Ip address 20.1.1.1   255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#keepalive
R2(config-if)#Exit

R2(config)#Interface serial 3/0
R2(config-if)#Ip address  1.1.1.2 255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/1
R2(config-if)#Ip address  2.2.2.1 255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#Exit


R2(config)#Interface loopback 0
R2(config-if)#Ip address 192.168.20.1 255.255.255.0
R2(config-if)#Exit
R2(config)#Interface loopback  1
R2(config-if)#Ip address 192.168.21.1 255.255.255.0
R2(config-if)#Exit
R2(config)#Interface loopback  2
R2(config-if)#Ip address 192.168.22.1 255.255.255.0
R2(config-if)#Exit
R2(config)#Interface loopback 3
R2(config-if)#Ip address 192.168.23.1  255.255




  
R3(config)#Interface fastethernet 0/0
R3(config-if)#Ip address 30.1.1.1   255.0.0.0
R3(config-if)#No shutdown
R3(config-if)# keepalive
R3(config-if)#Exit

R3(config)#Interface serial 3/1
R3(config-if)#Ip address  2.2.2.2 255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#Exit

R3(config)#Interface serial 3/2
R3(config-if)#Ip address  3.3.3.1 255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#Exit

R3(config)#Interface loopback 0
R3(config-if)#Ip address 192.168.30.1 255.255.255.0
R3(config-if)#Exit
R3(config)#
R3(config)#Interface loopback  1
R3(config-if)#Ip address 192.168.31.1 255.255.255.0
R3(config-if)#Exit
R3(config)#Interface loopback  2
R3(config-if)#Ip address 192.168.32.1 255.255.255.0
R3(config-if)#Exit
R3(config)#Interface loopback 3
R3(config-if)#Ip address 192.168.33.1  255.255.
R3(config-if)#Exit

R4(config)#interface fastEthernet 0/0
R4(config-if)#ip address 30.1.1.2 255.0.0.0
R4(config-if)#no shutdown
R4(config-if)#exit

R4(config)#interface loopback 0
R4(config-if)#ip address 192.168.40.1 255.255.255.0
R4(config-if)#exit



R5(config)#Interface fastethernet 0/0
R5(config-if)#Ip address 10.1.1.2   255.0.0.0
R5(config-if)#shutdown
R5(config-if)#Exit

R5(config)#Interface loopback 0
R5(config-if)#Ip address 192.168.50.1  255.255.255.0
R5(config-if)#Exit

R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                    1.1.1.1         YES manual up                    up
Serial3/2                    3.3.3.2         YES manual up                    up
Loopback0              192.168.10.1    YES manual up                    up
Loopback1              192.168.11.1    YES manual up                    up
Loopback2              192.168.12.1    YES manual up                    up
Loopback3              192.168.13.1    YES manual up                    up


R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.2         YES manual up                    up
Serial3/1                     2.2.2.1         YES manual up                    up
Loopback0              192.168.20.1    YES manual up                    up
Loopback1              192.168.21.1    YES manual up                    up
Loopback2              192.168.22.1    YES manual up                    up
Loopback3              192.168.23.1    YES manual up                    up


 R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                     2.2.2.2         YES manual up                    up
Serial3/2                     3.3.3.1         YES manual up                    up
Loopback0              192.168.30.1    YES manual up                    up
Loopback1              192.168.31.1    YES manual up                    up
Loopback2              192.168.32.1    YES manual up                    up
Loopback3              192.168.33.1    YES manual up                    up

  
R1(config)#router eigrp 65100
R1(config-router)#network 1.0.0.0
R1(config-router)#network 3.0.0.0
R1(config-router)#network 192.168.10.0
R1(config-router)#network 192.168.11.0
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.13.0
R1(config-router)#no auto-summary
R1(config-router)#exit

R2(config)#router eigrp 65100
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 192.168.20.0
R2(config-router)#network 192.168.21.0
R2(config-router)#network 192.168.22.0
R2(config-router)#network 192.168.23.0
R2(config-router)#no auto-summary
R2(config-router)#exit

R3(config)#router eigrp 65100
R3(config-router)#network 3.0.0.0
R3(config-router)#network 2.0.0.0
R3(config-router)#network 192.168.30.0
R3(config-router)#network 192.168.31.0
R3(config-router)#network 192.168.32.0
R3(config-router)#network 192.168.33.0
R3(config-router)#no auto-summary
R3(config-router)#exit



R1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(65100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   1.1.1.2                 Se3/0                    11 00:00:07   72   432  0  32
1   3.3.3.1                 Se3/2                    13 00:27:48   52   312  0  25


R2#show ip eigrp neighbor
EIGRP-IPv4 Neighbors for AS(65100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   2.2.2.2                 Se3/1                    14 00:00:37   61   366  0  24
0   1.1.1.1                 Se3/0                    14 00:00:37   48   288  0  32

R3#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(65100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
0   2.2.2.1                 Se3/1                    14 00:00:51  129   774  0  33
1   3.3.3.2                 Se3/2                    12 00:28:31   55   330  0  31






R1(config)#mpls label protocol ldp
R1(config)#mpls label range 99 199
R1(config)#mpls ldp router-id loopback 0
R1(config)#exit

R1(config)#interface serial 3/0
R1(config-if)#mpls ip
R1(config-if)#exit

R1(config)#interface serial 3/2
R1(config-if)#mpls ip
R1(config-if)#exit



R2(config)#mpls label protocol ldp
R2(config)#mpls label range 200 299
R2(config)#mpls ldp router-id loopback 0
R2(config)#exit

R2(config)#interface serial 3/0
R2(config-if)#mpls ip
R2(config-if)#exit

*Jan 19 01:34:45.107: %LDP-5-NBRCHG: LDP Neighbor 192.168.10.1:0 (1) is UP

R2(config)#interface serial 3/1
R2(config-if)#mpls ip
R2(config-if)#exit


R3(config)#mpls label protocol ldp
R3(config)#mpls label range 300 399
R3(config)#mpls ldp router-id loopback 0
R3(config)#exit

R3(config)#interface serial 3/1
R3(config-if)#mpls ip
R3(config-if)#exit

*Jan 19 01:42:35.227: %LDP-5-NBRCHG: LDP Neighbor 192.168.20.1:0 (1) is UP

R3(config)#interface serial 3/2
R3(config-if)#mpls ip
R3(config-if)#exit

*Jan 19 01:42:49.455: %LDP-5-NBRCHG: LDP Neighbor 192.168.10.1:0 (2) is UP

R1#show mpls ldp neighbor
    Peer LDP Ident: 192.168.20.1:0; Local LDP Ident 192.168.10.1:0
        TCP connection: 192.168.20.1.44766 - 192.168.10.1.646
        State: Oper; Msgs sent/rcvd: 26/25; Downstream
        Up time: 00:04:41
        LDP discovery sources:
          Serial3/0, Src IP addr: 1.1.1.2
        Addresses bound to peer LDP Ident:
          20.1.1.1        1.1.1.2         2.2.2.1         192.168.20.1
          192.168.21.1    192.168.22.1    192.168.23.1
    Peer LDP Ident: 192.168.30.1:0; Local LDP Ident 192.168.10.1:0
        TCP connection: 192.168.30.1.58247 - 192.168.10.1.646
        State: Oper; Msgs sent/rcvd: 23/23; Downstream
        Up time: 00:02:07
        LDP discovery sources:
          Serial3/2, Src IP addr: 3.3.3.1
        Addresses bound to peer LDP Ident:
          30.1.1.1        2.2.2.2         3.3.3.1         192.168.30.1
          192.168.31.1    192.168.32.1    192.168.33.1




R2#show mpls ldp neighbor
    Peer LDP Ident: 192.168.10.1:0; Local LDP Ident 192.168.20.1:0
        TCP connection: 192.168.10.1.646 - 192.168.20.1.44766
        State: Oper; Msgs sent/rcvd: 26/26; Downstream
        Up time: 00:04:53
        LDP discovery sources:
          Serial3/0, Src IP addr: 1.1.1.1
        Addresses bound to peer LDP Ident:
          10.1.1.1        1.1.1.1         3.3.3.2         192.168.10.1
          192.168.11.1    192.168.12.1    192.168.13.1
    Peer LDP Ident: 192.168.30.1:0; Local LDP Ident 192.168.20.1:0
        TCP connection: 192.168.30.1.61996 - 192.168.20.1.646
        State: Oper; Msgs sent/rcvd: 23/23; Downstream
        Up time: 00:02:33
        LDP discovery sources:
          Serial3/1, Src IP addr: 2.2.2.2
        Addresses bound to peer LDP Ident:
          30.1.1.1        2.2.2.2         3.3.3.1         192.168.30.1
          192.168.31.1    192.168.32.1    192.168.33.1




R3#show mpls ldp neighbor
    Peer LDP Ident: 192.168.20.1:0; Local LDP Ident 192.168.30.1:0
        TCP connection: 192.168.20.1.646 - 192.168.30.1.61996
        State: Oper; Msgs sent/rcvd: 23/23; Downstream
        Up time: 00:02:36
        LDP discovery sources:
          Serial3/1, Src IP addr: 2.2.2.1
        Addresses bound to peer LDP Ident:
          20.1.1.1        1.1.1.2         2.2.2.1         192.168.20.1
          192.168.21.1    192.168.22.1    192.168.23.1
    Peer LDP Ident: 192.168.10.1:0; Local LDP Ident 192.168.30.1:0
        TCP connection: 192.168.10.1.646 - 192.168.30.1.58247
        State: Oper; Msgs sent/rcvd: 23/23; Downstream
        Up time: 00:02:22
        LDP discovery sources:
          Serial3/2, Src IP addr: 3.3.3.2
        Addresses bound to peer LDP Ident:
          10.1.1.1        1.1.1.1         3.3.3.2         192.168.10.1
          192.168.11.1    192.168.12.1    192.168.13.1






R1(config)#ip vrf a-1
R1(config-vrf)#rd 100:1
R1(config-vrf)#route-target import 100:1
R1(config-vrf)#route-target export 100:1
R1(config-vrf)#exit



R3(config)#ip vrf a-2
R3(config-vrf)#rd 100:1
R3(config-vrf)#route-target both 100:1
R3(config-vrf)#exit



R1#show ip vrf a-1
  Name                             Default RD          Interfaces
  a-1                              100:1


R3#show ip vrf a-2
  Name                             Default RD          Interfaces
  a-2                              100:1




R1(config)#interface fastethernet 0/0
R1(config-if)#ip vrf forwarding a-1

% Interface FastEthernet0/0 IPv4 disabled and address(es) removed due to enabling VRF a-1

R1(config-if)#ip address 10.1.1.1 255.0.0.0
R1(config-if)#keepalive
R1(config-if)#no shutdown
R1(config-if)#exit




R3(config)#interface fastethernet 0/0
R3(config-if)#ip vrf forwarding a-2

% Interface FastEthernet0/0 IPv4 disabled and address(es) removed due to enabling VRF a-2

R3(config-if)#ip address 30.1.1.1 255.0.0.0
R3(config-if)#exit



R1#show run | section vrf
ip vrf a-1
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 ip vrf forwarding a-1





R3#show run | section vrf
ip vrf a-2
 rd 100:1
 route-target export 100:1
 route-target import 100:1
 ip vrf forwarding a-2



R1(config)#router rip
R1(config-router)#version 2
R1(config-router)#address-family ipv4 vrf a-1
R1(config-router-af)#network 10.0.0.0
R1(config-router-af)#no auto-summary
R1(config-router-af)#exit



R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#address-family ipv4 vrf a-2
R3(config-router-af)#network 30.0.0.0
R3(config-router-af)#no auto-summary
R3(config-router-af)#exit



R4(config)#router rip
R4(config-router)#version 2
R4(config-router)#network 30.0.0.0
R4(config-router)#network 192.168.40.0
R4(config-router)#no auto-summary
R4(config-router)#exit


R5(config)#router rip
R5(config-router)#version 2
R5(config-router)#network 10.0.0.0
R5(config-router)#network 192.168.50.0
R5(config-router)#no auto-summary
R5(config-router)#exit


R1#show ip route vrf a-1

Routing Table: a-1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, FastEthernet0/0
L        10.1.1.1/32 is directly connected, FastEthernet0/0
R     192.168.50.0/24 [120/1] via 10.1.1.2, 00:00:02, FastEthernet0/0



R3(config)#do show ip route vrf a-2

Routing Table: a-2
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        30.0.0.0/8 is directly connected, FastEthernet0/0
L        30.1.1.1/32 is directly connected, FastEthernet0/0
R     192.168.40.0/24 [120/1] via 30.1.1.2, 00:00:08, FastEthernet0/0



R1#ping vrf a-1 192.168.50.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/72/96 ms


R1#ping vrf a-2 192.168.40.1
vrf a-2 does not exist% Unable to find vrf 'a-2'



R1(config)#router bgp 65001
R1(config-router)#no bgp default ipv4-unicast
R1(config-router)#neighbor 192.168.30.1 remote-as 65001
R1(config-router)#neighbor 192.168.30.1 update-source loopback 0
R1(config-router)#address-family vpnv4 unicast
R1(config-router-af)#neighbor 192.168.30.1 activate
R1(config-router-af)#neighbor 192.168.30.1 send-community extended
R1(config-router-af)#neighbor 192.168.30.1 next-hop-self
R1(config-router-af)#end



R3(config)#router bgp 65001
R3(config-router)#no bgp default ipv4-unicast
R3(config-router)#neighbor 192.168.10.1 remote-as 65001
R3(config-router)#neighbor 192.168.10.1 update-source loopback 0
R3(config-router)#address-family vpnv4 unicast
R3(config-router-af)#neighbor 192.168.10.1 activate
R3(config-router-af)#neighbor 192.168.10.1 send-community extended
R3(config-router-af)#neighbor 192.168.10.1 next-hop-self
R3(config-router-af)#end

*Jan 19 02:23:37.103: %BGP-5-ADJCHANGE: neighbor 192.168.10.1 Up




R1#show ip bgp vpnv4 all summary
BGP router identifier 192.168.13.1, local AS number 65001
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.30.1    4        65001       5       6        1    0    0 00:01:41        0


R3#show ip bgp vpnv4 all summary
BGP router identifier 192.168.33.1, local AS number 65001
BGP table version is 1, main routing table version 1

Neighbor        V           AS MsgRcvd MsgSent   TblVer  InQ OutQ Up/Down  State/PfxRcd
192.168.10.1    4        65001       7       6        1    0    0 00:02:45        0



R1(config)#router bgp 65001
R1(config-router)#address-family ipv4 vrf a-1
R1(config-router-af)#redistribute rip
R1(config-router-af)#end


R1(config)#router rip
R1(config-router)#address-family ipv4 vrf a-1
R1(config-router-af)#redistribute bgp 65001 metric 2
R1(config-router-af)#exit


R3(config)#router bgp 65001
R3(config-router)#address-family ipv4 vrf a-2
R3(config-router-af)#redistribute rip
R3(config-router-af)#end


R3(config)#router rip
R3(config-router)#version 2
R3(config-router)#address-family ipv4 vrf a-2
R3(config-router-af)#redistribute BGP 65001 metric 2
R3(config-router-af)#end


R1#show ip route vrf a-1

Routing Table: a-1
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        10.0.0.0/8 is directly connected, FastEthernet0/0
L        10.1.1.1/32 is directly connected, FastEthernet0/0
B     30.0.0.0/8 [200/0] via 192.168.30.1, 00:05:06
B     192.168.40.0/24 [200/1] via 192.168.30.1, 00:05:06
R     192.168.50.0/24 [120/1] via 10.1.1.2, 00:00:08, FastEthernet0/0



R3#show ip route vrf a-2

Routing Table: a-2
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

B     10.0.0.0/8 [200/0] via 192.168.10.1, 00:06:53
      30.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        30.0.0.0/8 is directly connected, FastEthernet0/0
L        30.1.1.1/32 is directly connected, FastEthernet0/0
R     192.168.40.0/24 [120/1] via 30.1.1.2, 00:00:09, FastEthernet0/0
B     192.168.50.0/24 [200/1] via 192.168.10.1, 00:06:53




R4#ping 30.1.1.1 source 192.168.40.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.40.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/56/100 ms

R4#ping 192.168.50.1  source 192.168.40.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.50.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.40.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 108/132/144 ms


R5#ping 10.1.1.1 source 192.168.50.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.50.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/177/412 ms

R5#ping 192.168.40.1 source 192.168.50.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.40.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.50.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 152/185/196 ms



R1#ping 192.168.30.1 source 192.168.10.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.30.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.10.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 36/60/88 ms

R3#ping 192.168.10.1 source 192.168.30.1
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.10.1, timeout is 2 seconds:
Packet sent with a source address of 192.168.30.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 44/66/96 ms






Internetworks

Author & Editor

I am CCIE Technical Instructor/Network consultant. i am having experience of ranging from operating and maintaining PCs and peripherals to network control programs for multi-faceted data communication networks in LAN,MAN, and WAN environments.

0 comments: