How to configure MPLS LDP Peering ?

Label distributing protocol (LDP) is a protocol which is automatically generates and exchanges labels between MPLS routers. Each MPLS router will locally generate labels for its prefixes and then it will advertise the label values to its neighbors.



Label distributing protocol (LDP) is a protocol that automatically generates and exchanges labels between MPLS routers. Each MPLS router will locally generate labels for its prefixes and then it will advertise the label values to its neighbors.



before we start our we must be familiar with these topics :
  1. 1. Introduction of MPLS

    2. What is MPLS Label distributing protocol (LDP)? How LDP works?


    3. how to configure MPLS LDP Peering?


    4. What is MPLS L3 VPN? How to configure?


    5. How to configure MPLS L3 VPN with RIPv2?


    6. How to configure MPLS L3 VPN with EIGRP?


    7. How to configure MPLS L3 VPN with OSPF?


    8. What are OSPF Sham Links? how to configure OSPF Sham Links?


    9. How to configure MPLS L3 with BGP AS OVERRIDE?

    10. What Is Network Tunneling And How To Configure Generic Routing Encapsulation (GRE) Tunnels?

    11. What Is DMVPN (Dynamic Multipoint VPN), NHRP, MGRE, And How To Configure DMVPN Phase 1?

    12. What Is DMVPN (Dynamic Multipoint VPN) Phase 2? How To Configure DMVPN Phase 2 Dynamic And Static Mapping?

     13. How To Configure EIGRP And OSPF Over DMVPN Phase 1 & 2?

     14. How To Configure External BGP And EIGRP On DMVPN Phase 2?

    15.  What Is IPSec (Internet Protocol Security)? What Is Internet Key Exchange IKE? How To  Configure IPSec Tunnel?

    16. What Is IKE (Internet Key Exchange)? How To Configure IPSec Site-To-Site?

     

     



We will see many show commands do not skip it.  Let see the configurations:  

Topology:-


Task:
  • configure the topology as per the diagram 
  • assign the IP addresses as per our topology.
  • configure IGP EIGRP inside our MPLS network.
  • advertise directly connected interfaces and loopbacks interfaces 
  • configure MPLS on all our routers with LDP 
  • configure the labels 
  • enable IP cef

R1(config)#Interface fastethernet 0/0
R1(config-if)#Ip address 10.1.1.1   255.0.0.0
R1(config-if)#No shutdown
R1(config-if)#No keepalive
R1(config-if)#Exit

R1(config)#Interface serial 3/0
R1(config-if)#Ip address  1.1.1.1 255.0.0.0
R1(config-if)#No shutdown
R1(config-if)#Exit

R1(config)#Interface loopback 0
R1(config-if)#Ip address 192.168.10.1 255.255.255.0
R1(config-if)#Exit
R1(config)#Interface loopback 1
R1(config-if)#Ip address 192.168.11.1 255.255.255.0
R1(config-if)#Exit
R1(config)#Interface loopback 2
R1(config-if)#Ip address 192.168.12.1 255.255.255.0
R1(config-if)#Exit
R1(config)#Interface loopback 3
R1(config-if)#Ip address 192.168.13.1 255.255.255.0
R1(config-if)#Exit
R1(config)#Interface loopback 4
R1(config-if)#Ip address 192.168.14.1 255.255.255.0
R1(config-if)#Exit

R2(config)#Interface fastethernet 0/0
R2(config-if)#Ip address 20.1.1.1   255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#No keepalive
R2(config-if)#Exit

R2(config)#Interface serial 3/0
R2(config-if)#Ip address  1.1.1.2 255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface serial 3/1
R2(config-if)#Ip address  2.2.2.1 255.0.0.0
R2(config-if)#No shutdown
R2(config-if)#Exit

R2(config)#Interface loopback 0
R2(config-if)#Ip address 192.168.20.1 255.255.255.0
R2(config-if)#Exit
R2(config)#Interface loopback 1
R2(config-if)#Ip address 192.168.21.1 255.255.255.0
R2(config-if)#Exit
R2(config)#Interface loopback 2
R2(config-if)#Ip address 192.168.22.1 255.255.255.0
R2(config-if)#Exit
R2(config)#Interface loopback 3
R2(config-if)#Ip address 192.168.23.1 255.255.255.0
R2(config-if)#Exit
R2(config)#Interface loopback 4
R2(config-if)#Ip address 192.168.24.1 255.255.255.0
R2(config-if)#Exit

R3(config)#Interface fastethernet 0/0
R3(config-if)#Ip address 30.1.1.1   255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#No keepalive
R3(config-if)#Exit

R3(config)#Interface serial 3/1
R3(config-if)#Ip address  2.2.2.2 255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#Exit

R3(config)#Interface serial 3/2
R3(config-if)#Ip address  3.3.3.1 255.0.0.0
R3(config-if)#No shutdown
R3(config-if)#Exit

R3(config)#Interface loopback 0
R3(config-if)#Ip address 192.168.30.1 255.255.255.0
R3(config-if)#Exit
R3(config)#Interface loopback 1
R3(config-if)#Ip address 192.168.31.1 255.255.255.0
R3(config-if)#Exit
R3(config)#Interface loopback 2
R3(config-if)#Ip address 192.168.32.1 255.255.255.0
R3(config-if)#Exit
R3(config)#Interface loopback 3
R3(config-if)#Ip address 192.168.33.1 255.255.255.0
R3(config-if)#Exit
R3(config)#Interface loopback 4
R3(config-if)#Ip address 192.168.34.1 255.255.255.0

R4(config)#Interface fastethernet 0/0
R4(config-if)#Ip address 40.1.1.1   255.0.0.0
R4(config-if)#No shutdown
R4(config-if)#No keepalive
R4(config-if)#Exit

R4(config)#Interface serial 3/2
R4(config-if)#Ip address  3.3.3.2 255.0.0.0
R4(config-if)#No shutdown
R4(config-if)#Exit

R4(config)#Interface serial 3/3
R4(config-if)#Ip address  4.4.4.1  255.0.0.0
R4(config-if)#No shutdown
R4(config-if)#Exit

R4(config)#Interface loopback 0
R4(config-if)#Ip address 192.168.40.1 255.255.255.0
R4(config-if)#Exit
R4(config)#Interface loopback 1
R4(config-if)#Ip address 192.168.41.1 255.255.255.0
R4(config-if)#Exit
R4(config)#Interface loopback 2
R4(config-if)#Ip address 192.168.42.1 255.255.255.0
R4(config-if)#Exit
R4(config)#Interface loopback 3
R4(config-if)#Ip address 192.168.43.1 255.255.255.0
R4(config-if)#Exit
R4(config)#Interface loopback 4
R4(config-if)#Ip address 192.168.44.1 255.255.255.0
R4(config-if)#Exit

R5(config)#Interface fastethernet 0/0
R5(config-if)#Ip address 50.1.1.1   255.0.0.0
R5(config-if)#No shutdown
R5(config-if)#No keepalive
R5(config-if)#Exit

R5(config)#Interface serial 3/3
R5(config-if)#Ip address  4.4.4.2  255.0.0.0
R5(config-if)#No shutdown
R5(config-if)#Exit

R5(config)#Interface serial 3/4
R5(config-if)#Ip address  5.5.5.1  255.0.0.0
R5(config-if)#No shutdown
R5(config-if)#Exit

R5(config)#Interface loopback 0
R5(config-if)#Ip address 192.168.50.1 255.255.255.0
R5(config-if)#Exit
R5(config)#Interface loopback 1
R5(config-if)#Ip address 192.168.51.1 255.255.255.0
R5(config-if)#Exit
R5(config)#Interface loopback 2
R5(config-if)#Ip address 192.168.52.1 255.255.255.0
R5(config-if)#Exit
R5(config)#Interface loopback 3
R5(config-if)#Ip address 192.168.53.1 255.255.255.0
R5(config-if)#Exit
R5(config)#Interface loopback 4
R5(config-if)#Ip address 192.168.54.1 255.255.255.0
R5(config-if)#Exit


R1#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        10.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.1         YES manual up                    up
Serial3/4                     5.5.5.2         YES manual up                    up
Loopback0              192.168.10.1    YES manual up                    up
Loopback1              192.168.11.1    YES manual up                    up
Loopback2              192.168.12.1    YES manual up                    up
Loopback3              192.168.13.1    YES manual up                    up
Loopback4              192.168.14.1    YES manual up                    up

R2#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        20.1.1.1        YES manual up                    up
Serial3/0                     1.1.1.2         YES manual up                    up
Serial3/1                      2.2.2.1         YES manual up                    up
Loopback0              192.168.20.1    YES manual up                    up
Loopback1              192.168.21.1    YES manual up                    up
Loopback2              192.168.22.1    YES manual up                    up
Loopback3              192.168.23.1    YES manual up                    up
Loopback4              192.168.24.1    YES manual up                    up


R3#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        30.1.1.1        YES manual up                    up
Serial3/1                     2.2.2.2         YES manual up                    up
Serial3/2                     3.3.3.1         YES manual up                    up
Loopback0              192.168.30.1    YES manual up                    up
Loopback1              192.168.31.1    YES manual up                    up
Loopback2              192.168.32.1    YES manual up                    up
Loopback3              192.168.33.1    YES manual up                    up
Loopback4              192.168.34.1    YES manual up                    up

R4#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        40.1.1.1        YES manual up                    up
Serial3/2                    3.3.3.2         YES manual up                    up
Serial3/3                    4.4.4.1         YES manual up                    up
Loopback0              192.168.40.1    YES manual up                    up
Loopback1              192.168.41.1    YES manual up                    up
Loopback2              192.168.42.1    YES manual up                    up
Loopback3              192.168.43.1    YES manual up                    up
Loopback4              192.168.44.1    YES manual up                    up

R5#show ip interface brief
Interface              IP-Address      OK? Method Status                Protocol
FastEthernet0/0        50.1.1.1        YES manual up                    up
Serial3/3                     4.4.4.2         YES manual up                    up
Serial3/4                    5.5.5.1         YES manual up                    up
Loopback0              192.168.50.1    YES manual up                    up
Loopback1              192.168.51.1    YES manual up                    up
Loopback2              192.168.52.1    YES manual up                    up
Loopback3              192.168.53.1    YES manual up                    up
Loopback4              192.168.54.1    YES manual up                    up



R1(config)#router eigrp 100
R1(config-router)#network 1.0.0.0
R1(config-router)#network 10.0.0.0
R1(config-router)#network 5.0.0.0
R1(config-router)#network 192.168.10.0
R1(config-router)#network 192.168.11.0
R1(config-router)#network 192.168.12.0
R1(config-router)#network 192.168.13.0
R1(config-router)#network 192.168.14.0
R1(config-router)#exit

*Jan 13 23:08:05.527: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 5.5.5.1 (Serial3/4) is up: new adjacency
*Jan 13 23:00:42.855: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.1.1.2 (Serial3/0) is up: new adjacency

R2(config)#router eigrp 100
R2(config-router)#network 1.0.0.0
R2(config-router)#network 2.0.0.0
R2(config-router)#network 20.0.0.0
R2(config-router)#network 192.168.20.0
R2(config-router)#network 192.168.21.0
R2(config-router)#network 192.168.22.0
R2(config-router)#network 192.168.23.0
R2(config-router)#network 192.168.24.0
R2(config-router)#no auto-summary
R2(config-router)#exit

*Jan 13 23:00:43.051: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 1.1.1.1 (Serial3/0) is up: new adjacency

*Jan 13 23:01:28.959: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.2.2.2 (Serial3/1) is up: new adjacency

R3(config)#router eigrp 100
R3(config-router)#network 2.0.0.0
R3(config-router)#network 3.0.0.0
R3(config-router)#network 30.0.0.0
R3(config-router)#network 192.168.30.0
R3(config-router)#network 192.168.31.0
R3(config-router)#network 192.168.32.0
R3(config-router)#network 192.168.33.0
R3(config-router)#network 192.168.34.0
R3(config-router)#no auto-summary
R3(config-router)#exit

*Jan 13 23:01:28.923: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 2.2.2.1 (Serial3/1) is up: new adjacency

*Jan 13 23:02:21.035: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 3.3.3.2 (Serial3/2) is up: new adjacency

R4(config)#router eigrp 100
R4(config-router)#network 3.0.0.0
R4(config-router)#network 4.0.0.0
R4(config-router)#network 40.0.0.0
R4(config-router)#network 192.168.40.0
R4(config-router)#network 192.168.41.0
R4(config-router)#network 192.168.42.0
R4(config-router)#network 192.168.43.0
R4(config-router)#network 192.168.44.0
R4(config-router)#no auto-summary
R4(config-router)#exit

*Jan 13 23:00:01.159: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 3.3.3.1 (Serial3/2) is up: new adjacency

*Jan 13 23:05:19.831: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 4.4.4.2 (Serial3/3) is up: new adjacency

R5(config)#router eigrp 100
R5(config-router)#network 4.0.0.0
R5(config-router)#network 5.0.0.0
R5(config-router)#network 50.0.0.0
R5(config-router)#network 192.168.50.0
R5(config-router)#network 192.168.51.0
R5(config-router)#network 192.168.52.0
R5(config-router)#network 192.168.53.0
R5(config-router)#network 192.168.54.0
R5(config-router)#no auto-summary
R5(config-router)#exit

*Jan 13 23:02:52.051: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 4.4.4.1 (Serial3/3) is up: new adjacency

*Jan 13 23:03:17.651: %DUAL-5-NBRCHANGE: EIGRP-IPv4 100: Neighbor 5.5.5.2 (Serial3/4) is up: new adjacency



R1#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   5.5.5.1                 Se3/4                    13 00:08:02   68   408  0  7
0   1.1.1.2                 Se3/0                    13 00:15:25   65   390  0  20



R1#show ip route eigrp



Gateway of last resort is not set

D     2.0.0.0/8 [90/2681856] via 1.1.1.2, 00:08:18, Serial3/0
D     3.0.0.0/8 [90/3193856] via 5.5.5.1, 00:08:18, Serial3/4
                [90/3193856] via 1.1.1.2, 00:08:18, Serial3/0
D     4.0.0.0/8 [90/2681856] via 5.5.5.1, 00:08:18, Serial3/4
D     20.0.0.0/8 [90/2172416] via 1.1.1.2, 00:08:18, Serial3/0
D     30.0.0.0/8 [90/2684416] via 1.1.1.2, 00:08:18, Serial3/0
D     40.0.0.0/8 [90/2684416] via 5.5.5.1, 00:08:18, Serial3/4
D     50.0.0.0/8 [90/2172416] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.20.0/24 [90/2297856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.21.0/24 [90/2297856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.22.0/24 [90/2297856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.23.0/24 [90/2297856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.24.0/24 [90/2297856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.30.0/24 [90/2809856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.31.0/24 [90/2809856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.32.0/24 [90/2809856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.33.0/24 [90/2809856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.34.0/24 [90/2809856] via 1.1.1.2, 00:08:18, Serial3/0
D     192.168.40.0/24 [90/2809856] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.41.0/24 [90/2809856] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.42.0/24 [90/2809856] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.43.0/24 [90/2809856] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.44.0/24 [90/2809856] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.50.0/24 [90/2297856] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.51.0/24 [90/2297856] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.52.0/24 [90/2297856] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.53.0/24 [90/2297856] via 5.5.5.1, 00:08:18, Serial3/4
D     192.168.54.0/24 [90/2297856] via 5.5.5.1, 00:08:18, Serial3/4



R2#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   2.2.2.2                 Se3/1                    12 00:15:23   77   462  0  16
0   1.1.1.1                 Se3/0                    11 00:16:09   73   438  0  14
R2#show ip route eigrp


Gateway of last resort is not set

D     3.0.0.0/8 [90/2681856] via 2.2.2.2, 00:15:30, Serial3/1
D     4.0.0.0/8 [90/3193856] via 2.2.2.2, 00:08:55, Serial3/1
                [90/3193856] via 1.1.1.1, 00:08:55, Serial3/0
D     5.0.0.0/8 [90/2681856] via 1.1.1.1, 00:08:55, Serial3/0
D     10.0.0.0/8 [90/2172416] via 1.1.1.1, 00:16:18, Serial3/0
D     30.0.0.0/8 [90/2172416] via 2.2.2.2, 00:15:30, Serial3/1
D     40.0.0.0/8 [90/2684416] via 2.2.2.2, 00:08:55, Serial3/1
D     50.0.0.0/8 [90/2684416] via 1.1.1.1, 00:08:55, Serial3/0
D     192.168.10.0/24 [90/2297856] via 1.1.1.1, 00:16:18, Serial3/0
D     192.168.11.0/24 [90/2297856] via 1.1.1.1, 00:16:18, Serial3/0
D     192.168.12.0/24 [90/2297856] via 1.1.1.1, 00:16:18, Serial3/0
D     192.168.13.0/24 [90/2297856] via 1.1.1.1, 00:16:18, Serial3/0
D     192.168.14.0/24 [90/2297856] via 1.1.1.1, 00:16:18, Serial3/0
D     192.168.30.0/24 [90/2297856] via 2.2.2.2, 00:15:30, Serial3/1
D     192.168.31.0/24 [90/2297856] via 2.2.2.2, 00:15:30, Serial3/1
D     192.168.32.0/24 [90/2297856] via 2.2.2.2, 00:15:30, Serial3/1
D     192.168.33.0/24 [90/2297856] via 2.2.2.2, 00:15:30, Serial3/1
D     192.168.34.0/24 [90/2297856] via 2.2.2.2, 00:15:30, Serial3/1
D     192.168.40.0/24 [90/2809856] via 2.2.2.2, 00:08:55, Serial3/1
D     192.168.41.0/24 [90/2809856] via 2.2.2.2, 00:08:55, Serial3/1
D     192.168.42.0/24 [90/2809856] via 2.2.2.2, 00:08:55, Serial3/1
D     192.168.43.0/24 [90/2809856] via 2.2.2.2, 00:08:55, Serial3/1
D     192.168.44.0/24 [90/2809856] via 2.2.2.2, 00:08:55, Serial3/1
D     192.168.50.0/24 [90/2809856] via 1.1.1.1, 00:08:55, Serial3/0
D     192.168.51.0/24 [90/2809856] via 1.1.1.1, 00:08:55, Serial3/0
D     192.168.52.0/24 [90/2809856] via 1.1.1.1, 00:08:55, Serial3/0
D     192.168.53.0/24 [90/2809856] via 1.1.1.1, 00:08:55, Serial3/0
D     192.168.54.0/24 [90/2809856] via 1.1.1.1, 00:08:55, Serial3/0




R3#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   3.3.3.2                 Se3/2                    14 00:14:52   99   594  0  11
0   2.2.2.1                 Se3/1                    14 00:15:44  394  2364  0  21
R3#show ip route eigrp

Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 2.2.2.1, 00:15:49, Serial3/1
D     4.0.0.0/8 [90/2681856] via 3.3.3.2, 00:14:58, Serial3/2
D     5.0.0.0/8 [90/3193856] via 3.3.3.2, 00:09:14, Serial3/2
                [90/3193856] via 2.2.2.1, 00:09:14, Serial3/1
D     10.0.0.0/8 [90/2684416] via 2.2.2.1, 00:09:14, Serial3/1
D     20.0.0.0/8 [90/2172416] via 2.2.2.1, 00:15:49, Serial3/1
D     40.0.0.0/8 [90/2172416] via 3.3.3.2, 00:14:58, Serial3/2
D     50.0.0.0/8 [90/2684416] via 3.3.3.2, 00:09:14, Serial3/2
D     192.168.10.0/24 [90/2809856] via 2.2.2.1, 00:09:14, Serial3/1
D     192.168.11.0/24 [90/2809856] via 2.2.2.1, 00:09:14, Serial3/1
D     192.168.12.0/24 [90/2809856] via 2.2.2.1, 00:09:14, Serial3/1
D     192.168.13.0/24 [90/2809856] via 2.2.2.1, 00:09:14, Serial3/1
D     192.168.14.0/24 [90/2809856] via 2.2.2.1, 00:09:14, Serial3/1
D     192.168.20.0/24 [90/2297856] via 2.2.2.1, 00:15:49, Serial3/1
D     192.168.21.0/24 [90/2297856] via 2.2.2.1, 00:15:49, Serial3/1
D     192.168.22.0/24 [90/2297856] via 2.2.2.1, 00:15:49, Serial3/1
D     192.168.23.0/24 [90/2297856] via 2.2.2.1, 00:15:49, Serial3/1
D     192.168.24.0/24 [90/2297856] via 2.2.2.1, 00:15:49, Serial3/1
D     192.168.40.0/24 [90/2297856] via 3.3.3.2, 00:14:58, Serial3/2
D     192.168.41.0/24 [90/2297856] via 3.3.3.2, 00:14:58, Serial3/2
D     192.168.42.0/24 [90/2297856] via 3.3.3.2, 00:14:58, Serial3/2
D     192.168.43.0/24 [90/2297856] via 3.3.3.2, 00:14:58, Serial3/2
D     192.168.44.0/24 [90/2297856] via 3.3.3.2, 00:14:58, Serial3/2
D     192.168.50.0/24 [90/2809856] via 3.3.3.2, 00:09:14, Serial3/2
D     192.168.51.0/24 [90/2809856] via 3.3.3.2, 00:09:14, Serial3/2
D     192.168.52.0/24 [90/2809856] via 3.3.3.2, 00:09:14, Serial3/2
D     192.168.53.0/24 [90/2809856] via 3.3.3.2, 00:09:14, Serial3/2
D     192.168.54.0/24 [90/2809856] via 3.3.3.2, 00:09:14, Serial3/2



R4#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   4.4.4.2                 Se3/3                    12 00:09:50  117   702  0  8
0   3.3.3.1                 Se3/2                    11 00:15:09   91   546  0  15
R4#show ip route eigrp


Gateway of last resort is not set

D     1.0.0.0/8 [90/3193856] via 4.4.4.2, 00:09:31, Serial3/3
                [90/3193856] via 3.3.3.1, 00:09:31, Serial3/2
D     2.0.0.0/8 [90/2681856] via 3.3.3.1, 00:15:15, Serial3/2
D     5.0.0.0/8 [90/2681856] via 4.4.4.2, 00:09:57, Serial3/3
D     10.0.0.0/8 [90/2684416] via 4.4.4.2, 00:09:31, Serial3/3
D     20.0.0.0/8 [90/2684416] via 3.3.3.1, 00:09:31, Serial3/2
D     30.0.0.0/8 [90/2172416] via 3.3.3.1, 00:15:15, Serial3/2
D     50.0.0.0/8 [90/2172416] via 4.4.4.2, 00:09:57, Serial3/3
D     192.168.10.0/24 [90/2809856] via 4.4.4.2, 00:09:31, Serial3/3
D     192.168.11.0/24 [90/2809856] via 4.4.4.2, 00:09:31, Serial3/3
D     192.168.12.0/24 [90/2809856] via 4.4.4.2, 00:09:31, Serial3/3
D     192.168.13.0/24 [90/2809856] via 4.4.4.2, 00:09:31, Serial3/3
D     192.168.14.0/24 [90/2809856] via 4.4.4.2, 00:09:31, Serial3/3
D     192.168.20.0/24 [90/2809856] via 3.3.3.1, 00:09:31, Serial3/2
D     192.168.21.0/24 [90/2809856] via 3.3.3.1, 00:09:31, Serial3/2
D     192.168.22.0/24 [90/2809856] via 3.3.3.1, 00:09:31, Serial3/2
D     192.168.23.0/24 [90/2809856] via 3.3.3.1, 00:09:31, Serial3/2
D     192.168.24.0/24 [90/2809856] via 3.3.3.1, 00:09:31, Serial3/2
D     192.168.30.0/24 [90/2297856] via 3.3.3.1, 00:15:15, Serial3/2
D     192.168.31.0/24 [90/2297856] via 3.3.3.1, 00:15:15, Serial3/2
D     192.168.32.0/24 [90/2297856] via 3.3.3.1, 00:15:15, Serial3/2
D     192.168.33.0/24 [90/2297856] via 3.3.3.1, 00:15:15, Serial3/2
D     192.168.34.0/24 [90/2297856] via 3.3.3.1, 00:15:15, Serial3/2
D     192.168.50.0/24 [90/2297856] via 4.4.4.2, 00:09:57, Serial3/3
D     192.168.51.0/24 [90/2297856] via 4.4.4.2, 00:09:57, Serial3/3
D     192.168.52.0/24 [90/2297856] via 4.4.4.2, 00:09:56, Serial3/3
D     192.168.53.0/24 [90/2297856] via 4.4.4.2, 00:09:56, Serial3/3
D     192.168.54.0/24 [90/2297856] via 4.4.4.2, 00:09:56, Serial3/3




R5#show ip eigrp neighbors
EIGRP-IPv4 Neighbors for AS(100)
H   Address                 Interface              Hold Uptime   SRTT   RTO  Q  Seq
                                                   (sec)         (ms)       Cnt Num
1   5.5.5.2                 Se3/4                    14 00:09:47   73   438  0  16
0   4.4.4.1                 Se3/3                    13 00:10:12  106   636  0  10
R5#show ip route eigrp

Gateway of last resort is not set

D     1.0.0.0/8 [90/2681856] via 5.5.5.2, 00:09:56, Serial3/4
D     2.0.0.0/8 [90/3193856] via 5.5.5.2, 00:09:56, Serial3/4
                [90/3193856] via 4.4.4.1, 00:09:56, Serial3/3
D     3.0.0.0/8 [90/2681856] via 4.4.4.1, 00:10:22, Serial3/3
D     10.0.0.0/8 [90/2172416] via 5.5.5.2, 00:09:56, Serial3/4
D     20.0.0.0/8 [90/2684416] via 5.5.5.2, 00:09:56, Serial3/4
D     30.0.0.0/8 [90/2684416] via 4.4.4.1, 00:09:56, Serial3/3
D     40.0.0.0/8 [90/2172416] via 4.4.4.1, 00:10:22, Serial3/3
D     192.168.10.0/24 [90/2297856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.11.0/24 [90/2297856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.12.0/24 [90/2297856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.13.0/24 [90/2297856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.14.0/24 [90/2297856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.20.0/24 [90/2809856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.21.0/24 [90/2809856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.22.0/24 [90/2809856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.23.0/24 [90/2809856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.24.0/24 [90/2809856] via 5.5.5.2, 00:09:56, Serial3/4
D     192.168.30.0/24 [90/2809856] via 4.4.4.1, 00:09:56, Serial3/3
D     192.168.31.0/24 [90/2809856] via 4.4.4.1, 00:09:56, Serial3/3
D     192.168.32.0/24 [90/2809856] via 4.4.4.1, 00:09:56, Serial3/3
D     192.168.33.0/24 [90/2809856] via 4.4.4.1, 00:09:56, Serial3/3
D     192.168.34.0/24 [90/2809856] via 4.4.4.1, 00:09:56, Serial3/3
D     192.168.40.0/24 [90/2297856] via 4.4.4.1, 00:10:22, Serial3/3
D     192.168.41.0/24 [90/2297856] via 4.4.4.1, 00:10:22, Serial3/3
D     192.168.42.0/24 [90/2297856] via 4.4.4.1, 00:10:22, Serial3/3
D     192.168.43.0/24 [90/2297856] via 4.4.4.1, 00:10:22, Serial3/3
D     192.168.44.0/24 [90/2297856] via 4.4.4.1, 00:10:22, Serial3/3



 R1(config)#ip cef

R1(config)#mpls label protocol ldp
R1(config)#mpls label range 99 199
R1(config)#mpls ldp router-id loopback 0
R1(config)#end

R1(config)#interface serial 3/0
R1(config-if)#mpls ip
R1(config-if)#exit
R1(config)#interface serial 3/4
R1(config-if)#mpls ip
R1(config-if)#exit


*Jan 13 23:32:04.343: %LDP-5-NBRCHG: LDP Neighbor 192.168.20.1:0 (1) is UP

*Jan 13 23:40:16.115: %LDP-5-NBRCHG: LDP Neighbor 192.168.50.1:0 (2) is UP


R2(config)#ip cef

R2(config)#mpls label protocol ldp

R2(config)#mpls label range 200 299
R2(config)#mpls ldp router-id loopback 0
R2(config)#end

R2(config)#interface serial 3/0
R2(config-if)#mpls ip
R2(config-if)#exit

R2(config)#interface serial 3/1
R2(config-if)#mpls ip
R2(config-if)#exit


*Jan 13 23:32:04.331: %LDP-5-NBRCHG: LDP Neighbor 192.168.10.1:0 (1) is UP

*Jan 13 23:35:07.419: %LDP-5-NBRCHG: LDP Neighbor 192.168.30.1:0 (2) is UP




 R3(config)#ip cef
 R3(config)#mpls label protocol ldp

R3(config)#mpls label range 300 399
R3(config)#mpls ldp router-id loopback 0
R3(config)#end
R3#
*Jan 13 23:34:37.059: %SYS-5-CONFIG_I: Configured from console by console


R3(config)#interface serial 3/1
R3(config-if)#mpls ip
R3(config-if)#exit

R3(config)#interface serial 3/2
R3(config-if)#mpls ip
R3(config-if)#exit

*Jan 13 23:35:07.247: %LDP-5-NBRCHG: LDP Neighbor 192.168.20.1:0 (1) is UP

*Jan 13 23:38:20.891: %LDP-5-NBRCHG: LDP Neighbor 192.168.40.1:0 (2) is UP

R4(config)#ip cef
R4(config)#mpls label protocol ldp
R4(config)#mpls label range 400 499
R4(config)#mpls ldp router-id loopback 0
R4(config)#end

R4(config)#interface serial 3/2
R4(config-if)#mpls ip
R4(config-if)#exit

R4(config)#interface serial 3/3
R4(config-if)#mpls ip
R4(config-if)#exit

*Jan 13 23:36:00.847: %LDP-5-NBRCHG: LDP Neighbor 192.168.30.1:0 (1) is UP

*Jan 13 23:37:44.515: %LDP-5-NBRCHG: LDP Neighbor 192.168.50.1:0 (2) is UP




 R5(config)#ip cef

R5(config)#mpls label protocol ldp
R5(config)#mpls label range 500 599
R5(config)#mpls ldp router-id loopback 0
R5(config)#end

R5(config)#interface serial 3/3
R5(config-if)#mpls ip
R5(config-if)#exit

R5(config)#interface serial 3/4
R5(config-if)#mpls ip
R5(config-if)#exit


 *Jan 13 23:35:16.571: %LDP-5-NBRCHG: LDP Neighbor 192.168.40.1:0 (1) is UP

 *Jan 13 23:35:28.091: %LDP-5-NBRCHG: LDP Neighbor 192.168.10.1:0 (2) is UP


 R1#show mpls ldp neighbor

    Peer LDP Ident: 192.168.20.1:0; Local LDP Ident 192.168.10.1:0
        TCP connection: 192.168.20.1.60491 - 192.168.10.1.646
        State: Oper; Msgs sent/rcvd: 54/55; Downstream
        Up time: 00:14:19
        LDP discovery sources:
          Serial3/0, Src IP addr: 1.1.1.2
        Addresses bound to peer LDP Ident:
          20.1.1.1        1.1.1.2         2.2.2.1         192.168.20.1
          192.168.21.1    192.168.22.1    192.168.23.1    192.168.24.1
    Peer LDP Ident: 192.168.50.1:0; Local LDP Ident 192.168.10.1:0
        TCP connection: 192.168.50.1.27925 - 192.168.10.1.646
        State: Oper; Msgs sent/rcvd: 45/45; Downstream
        Up time: 00:06:07
        LDP discovery sources:
          Serial3/4, Src IP addr: 5.5.5.1
        Addresses bound to peer LDP Ident:
          50.1.1.1        4.4.4.2         5.5.5.1         192.168.50.1
          192.168.51.1    192.168.52.1    192.168.53.1    192.168.54.1



R2#show mpls ldp neighbor
    Peer LDP Ident: 192.168.10.1:0; Local LDP Ident 192.168.20.1:0
        TCP connection: 192.168.10.1.646 - 192.168.20.1.60491
        State: Oper; Msgs sent/rcvd: 55/55; Downstream
        Up time: 00:14:50
        LDP discovery sources:
          Serial3/0, Src IP addr: 1.1.1.1
        Addresses bound to peer LDP Ident:
          10.1.1.1        1.1.1.1         5.5.5.2         192.168.10.1
          192.168.11.1    192.168.12.1    192.168.13.1    192.168.14.1
    Peer LDP Ident: 192.168.30.1:0; Local LDP Ident 192.168.20.1:0
        TCP connection: 192.168.30.1.56343 - 192.168.20.1.646
        State: Oper; Msgs sent/rcvd: 51/51; Downstream
        Up time: 00:11:47
        LDP discovery sources:
          Serial3/1, Src IP addr: 2.2.2.2
        Addresses bound to peer LDP Ident:
          30.1.1.1        2.2.2.2         3.3.3.1         192.168.30.1
          192.168.31.1    192.168.32.1    192.168.33.1    192.168.34.1


R3#show mpls ldp neighbor
    Peer LDP Ident: 192.168.20.1:0; Local LDP Ident 192.168.30.1:0
        TCP connection: 192.168.20.1.646 - 192.168.30.1.56343
        State: Oper; Msgs sent/rcvd: 52/52; Downstream
        Up time: 00:12:23
        LDP discovery sources:
          Serial3/1, Src IP addr: 2.2.2.1
        Addresses bound to peer LDP Ident:
          20.1.1.1        1.1.1.2         2.2.2.1         192.168.20.1
          192.168.21.1    192.168.22.1    192.168.23.1    192.168.24.1
    Peer LDP Ident: 192.168.40.1:0; Local LDP Ident 192.168.30.1:0
        TCP connection: 192.168.40.1.19139 - 192.168.30.1.646
        State: Oper; Msgs sent/rcvd: 48/48; Downstream
        Up time: 00:09:10
        LDP discovery sources:
          Serial3/2, Src IP addr: 3.3.3.2
        Addresses bound to peer LDP Ident:
          40.1.1.1        3.3.3.2         4.4.4.1         192.168.40.1
          192.168.41.1    192.168.42.1    192.168.43.1    192.168.44.1

R4#show mpls ldp neighbor
    Peer LDP Ident: 192.168.30.1:0; Local LDP Ident 192.168.40.1:0
        TCP connection: 192.168.30.1.646 - 192.168.40.1.19139
        State: Oper; Msgs sent/rcvd: 48/48; Downstream
        Up time: 00:09:33
        LDP discovery sources:
          Serial3/2, Src IP addr: 3.3.3.1
        Addresses bound to peer LDP Ident:
          30.1.1.1        2.2.2.2         3.3.3.1         192.168.30.1
          192.168.31.1    192.168.32.1    192.168.33.1    192.168.34.1
    Peer LDP Ident: 192.168.50.1:0; Local LDP Ident 192.168.40.1:0
        TCP connection: 192.168.50.1.13984 - 192.168.40.1.646
        State: Oper; Msgs sent/rcvd: 47/46; Downstream
        Up time: 00:07:49
        LDP discovery sources:
          Serial3/3, Src IP addr: 4.4.4.2
        Addresses bound to peer LDP Ident:
          50.1.1.1        4.4.4.2         5.5.5.1         192.168.50.1
          192.168.51.1    192.168.52.1    192.168.53.1    192.168.54.1


R5#show mpls ldp neighbor
    Peer LDP Ident: 192.168.40.1:0; Local LDP Ident 192.168.50.1:0
        TCP connection: 192.168.40.1.646 - 192.168.50.1.13984
        State: Oper; Msgs sent/rcvd: 47/47; Downstream
        Up time: 00:08:10
        LDP discovery sources:
          Serial3/3, Src IP addr: 4.4.4.1
        Addresses bound to peer LDP Ident:
          40.1.1.1        3.3.3.2         4.4.4.1         192.168.40.1
          192.168.41.1    192.168.42.1    192.168.43.1    192.168.44.1
    Peer LDP Ident: 192.168.10.1:0; Local LDP Ident 192.168.50.1:0
        TCP connection: 192.168.10.1.646 - 192.168.50.1.27925
        State: Oper; Msgs sent/rcvd: 46/47; Downstream
        Up time: 00:07:58
        LDP discovery sources:
          Serial3/4, Src IP addr: 5.5.5.2
        Addresses bound to peer LDP Ident:
          10.1.1.1        1.1.1.1         5.5.5.2         192.168.10.1
          192.168.11.1    192.168.12.1    192.168.13.1    192.168.14.1



R1#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
99         Pop Label  2.0.0.0/8        0             Se3/0      point2point
100        200        3.0.0.0/8        0             Se3/0      point2point
           502        3.0.0.0/8        0             Se3/4      point2point
101        Pop Label  4.0.0.0/8        0             Se3/4      point2point
102        Pop Label  20.0.0.0/8       192           Se3/0      point2point
103        204        30.0.0.0/8       0             Se3/0      point2point
104        506        40.0.0.0/8       0             Se3/4      point2point
105        Pop Label  50.0.0.0/8       96            Se3/4      point2point
106        Pop Label  192.168.20.0/24  0             Se3/0      point2point
107        Pop Label  192.168.21.0/24  0             Se3/0      point2point
108        Pop Label  192.168.22.0/24  0             Se3/0      point2point
109        Pop Label  192.168.23.0/24  0             Se3/0      point2point
110        Pop Label  192.168.24.0/24  0             Se3/0      point2point
111        212        192.168.30.0/24  0             Se3/0      point2point
112        213        192.168.31.0/24  0             Se3/0      point2point
113        214        192.168.32.0/24  0             Se3/0      point2point
114        215        192.168.33.0/24  0             Se3/0      point2point
115        216        192.168.34.0/24  0             Se3/0      point2point
116        522        192.168.40.0/24  0             Se3/4      point2point
117        523        192.168.41.0/24  0             Se3/4      point2point
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
118        524        192.168.42.0/24  0             Se3/4      point2point
119        525        192.168.43.0/24  0             Se3/4      point2point
120        526        192.168.44.0/24  0             Se3/4      point2point
121        Pop Label  192.168.50.0/24  0             Se3/4      point2point
122        Pop Label  192.168.51.0/24  0             Se3/4      point2point
123        Pop Label  192.168.52.0/24  0             Se3/4      point2point
124        Pop Label  192.168.53.0/24  0             Se3/4      point2point
125        Pop Label  192.168.54.0/24  0             Se3/4      point2point



R2#show mpls forwarding
R2#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
200        Pop Label  3.0.0.0/8        0             Se3/1      point2point
201        101        4.0.0.0/8        0             Se3/0      point2point
           301        4.0.0.0/8        0             Se3/1      point2point
202        Pop Label  5.0.0.0/8        0             Se3/0      point2point
203        Pop Label  10.0.0.0/8       96            Se3/0      point2point
204        Pop Label  30.0.0.0/8       96            Se3/1      point2point
205        305        40.0.0.0/8       0             Se3/1      point2point
206        105        50.0.0.0/8       0             Se3/0      point2point
207        Pop Label  192.168.10.0/24  0             Se3/0      point2point
208        Pop Label  192.168.11.0/24  0             Se3/0      point2point
209        Pop Label  192.168.12.0/24  0             Se3/0      point2point
210        Pop Label  192.168.13.0/24  0             Se3/0      point2point
211        Pop Label  192.168.14.0/24  0             Se3/0      point2point
212        Pop Label  192.168.30.0/24  0             Se3/1      point2point
213        Pop Label  192.168.31.0/24  0             Se3/1      point2point
214        Pop Label  192.168.32.0/24  0             Se3/1      point2point
215        Pop Label  192.168.33.0/24  0             Se3/1      point2point
216        Pop Label  192.168.34.0/24  0             Se3/1      point2point
217        317        192.168.40.0/24  0             Se3/1      point2point
218        318        192.168.41.0/24  0             Se3/1      point2point
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
219        319        192.168.42.0/24  0             Se3/1      point2point
220        320        192.168.43.0/24  0             Se3/1      point2point
221        321        192.168.44.0/24  0             Se3/1      point2point
222        121        192.168.50.0/24  0             Se3/0      point2point
223        122        192.168.51.0/24  0             Se3/0      point2point
224        123        192.168.52.0/24  0             Se3/0      point2point
225        124        192.168.53.0/24  0             Se3/0      point2point
226        125        192.168.54.0/24  0             Se3/0      point2point

R3#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
300        Pop Label  1.0.0.0/8        0             Se3/1      point2point
301        Pop Label  4.0.0.0/8        0             Se3/2      point2point
302        202        5.0.0.0/8        0             Se3/1      point2point
           402        5.0.0.0/8        0             Se3/2      point2point
303        203        10.0.0.0/8       0             Se3/1      point2point
304        Pop Label  20.0.0.0/8       192           Se3/1      point2point
305        Pop Label  40.0.0.0/8       96            Se3/2      point2point
306        406        50.0.0.0/8       0             Se3/2      point2point
307        207        192.168.10.0/24  0             Se3/1      point2point
308        208        192.168.11.0/24  0             Se3/1      point2point
309        209        192.168.12.0/24  0             Se3/1      point2point
310        210        192.168.13.0/24  0             Se3/1      point2point
311        211        192.168.14.0/24  0             Se3/1      point2point
312        Pop Label  192.168.20.0/24  0             Se3/1      point2point
313        Pop Label  192.168.21.0/24  0             Se3/1      point2point
314        Pop Label  192.168.22.0/24  0             Se3/1      point2point
315        Pop Label  192.168.23.0/24  0             Se3/1      point2point
316        Pop Label  192.168.24.0/24  0             Se3/1      point2point
317        Pop Label  192.168.40.0/24  0             Se3/2      point2point
318        Pop Label  192.168.41.0/24  0             Se3/2      point2point
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
319        Pop Label  192.168.42.0/24  0             Se3/2      point2point
320        Pop Label  192.168.43.0/24  0             Se3/2      point2point
321        Pop Label  192.168.44.0/24  0             Se3/2      point2point
322        422        192.168.50.0/24  0             Se3/2      point2point
323        423        192.168.51.0/24  0             Se3/2      point2point
324        424        192.168.52.0/24  0             Se3/2      point2point
325        425        192.168.53.0/24  0             Se3/2      point2point
326        426        192.168.54.0/24  0             Se3/2      point2point


R4#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
400        300        1.0.0.0/8        0             Se3/2      point2point
           500        1.0.0.0/8        0             Se3/3      point2point
401        Pop Label  2.0.0.0/8        0             Se3/2      point2point
402        Pop Label  5.0.0.0/8        0             Se3/3      point2point
403        503        10.0.0.0/8       0             Se3/3      point2point
404        304        20.0.0.0/8       0             Se3/2      point2point
405        Pop Label  30.0.0.0/8       96            Se3/2      point2point
406        Pop Label  50.0.0.0/8       96            Se3/3      point2point
407        507        192.168.10.0/24  0             Se3/3      point2point
408        508        192.168.11.0/24  0             Se3/3      point2point
409        509        192.168.12.0/24  0             Se3/3      point2point
410        510        192.168.13.0/24  0             Se3/3      point2point
411        511        192.168.14.0/24  0             Se3/3      point2point
412        312        192.168.20.0/24  0             Se3/2      point2point
413        313        192.168.21.0/24  0             Se3/2      point2point
414        314        192.168.22.0/24  0             Se3/2      point2point
415        315        192.168.23.0/24  0             Se3/2      point2point
416        316        192.168.24.0/24  0             Se3/2      point2point
417        Pop Label  192.168.30.0/24  0             Se3/2      point2point
418        Pop Label  192.168.31.0/24  0             Se3/2      point2point
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
419        Pop Label  192.168.32.0/24  0             Se3/2      point2point
420        Pop Label  192.168.33.0/24  0             Se3/2      point2point
421        Pop Label  192.168.34.0/24  0             Se3/2      point2point
422        Pop Label  192.168.50.0/24  0             Se3/3      point2point
423        Pop Label  192.168.51.0/24  0             Se3/3      point2point
424        Pop Label  192.168.52.0/24  0             Se3/3      point2point
425        Pop Label  192.168.53.0/24  0             Se3/3      point2point
426        Pop Label  192.168.54.0/24  0             Se3/3      point2point



R5#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
500        Pop Label  1.0.0.0/8        0             Se3/4      point2point
501        401        2.0.0.0/8        0             Se3/3      point2point
           99         2.0.0.0/8        0             Se3/4      point2point
502        Pop Label  3.0.0.0/8        0             Se3/3      point2point
503        Pop Label  10.0.0.0/8       96            Se3/4      point2point
504        102        20.0.0.0/8       0             Se3/4      point2point
505        405        30.0.0.0/8       0             Se3/3      point2point
506        Pop Label  40.0.0.0/8       96            Se3/3      point2point
507        Pop Label  192.168.10.0/24  0             Se3/4      point2point
508        Pop Label  192.168.11.0/24  0             Se3/4      point2point
509        Pop Label  192.168.12.0/24  0             Se3/4      point2point
510        Pop Label  192.168.13.0/24  0             Se3/4      point2point
511        Pop Label  192.168.14.0/24  0             Se3/4      point2point
512        106        192.168.20.0/24  0             Se3/4      point2point
513        107        192.168.21.0/24  0             Se3/4      point2point
514        108        192.168.22.0/24  0             Se3/4      point2point
515        109        192.168.23.0/24  0             Se3/4      point2point
516        110        192.168.24.0/24  0             Se3/4      point2point
517        417        192.168.30.0/24  0             Se3/3      point2point
518        418        192.168.31.0/24  0             Se3/3      point2point
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
519        419        192.168.32.0/24  0             Se3/3      point2point
520        420        192.168.33.0/24  0             Se3/3      point2point
521        421        192.168.34.0/24  0             Se3/3      point2point
522        Pop Label  192.168.40.0/24  0             Se3/3      point2point
523        Pop Label  192.168.41.0/24  0             Se3/3      point2point
524        Pop Label  192.168.42.0/24  0             Se3/3      point2point
525        Pop Label  192.168.43.0/24  0             Se3/3      point2point
526        Pop Label  192.168.44.0/24  0             Se3/3      point2point
`


R1# traceroute 30.1.1.1
Type escape sequence to abort.
Tracing the route to 30.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.2 [MPLS: Label 204 Exp 0] 12 msec 316 msec 152 msec
  2 2.2.2.2 156 msec 108 msec 168 msec

R1# traceroute 40.1.1.1
Type escape sequence to abort.
Tracing the route to 40.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 5.5.5.1 [MPLS: Label 506 Exp 0] 84 msec 56 msec 100 msec
  2 4.4.4.1 160 msec 100 msec 140 msec





 R2#traceroute 50.1.1.1

Type escape sequence to abort.
Tracing the route to 50.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 1.1.1.1 [MPLS: Label 105 Exp 0] 200 msec 56 msec 48 msec
  2 5.5.5.1 140 msec 104 msec 168 msec

R2#traceroute 40.1.1.1
Type escape sequence to abort.
Tracing the route to 40.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 2.2.2.2 [MPLS: Label 305 Exp 0] 56 msec 72 msec 24 msec
  2 3.3.3.2 128 msec 116 msec 124 msec



R3#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 2.2.2.1 [MPLS: Label 203 Exp 0] 124 msec 76 msec 40 msec
  2 1.1.1.1 156 msec 144 msec 112 msec

R3#traceroute 50.1.1.1
Type escape sequence to abort.
Tracing the route to 50.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 3.3.3.2 [MPLS: Label 406 Exp 0] 80 msec 48 msec 96 msec
  2 4.4.4.2 120 msec 168 msec 116 msec



 R4#traceroute 20.1.1.1

Type escape sequence to abort.
Tracing the route to 20.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 3.3.3.1 [MPLS: Label 304 Exp 0] 40 msec 76 msec 4 msec
  2 2.2.2.1 88 msec 80 msec 32 msec

R4#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 4.4.4.2 [MPLS: Label 503 Exp 0] 40 msec 76 msec 80 msec
  2 5.5.5.2 180 msec 168 msec 140 msec

R5#traceroute 30.1.1.1
Type escape sequence to abort.
Tracing the route to 30.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 4.4.4.1 [MPLS: Label 405 Exp 0] 20 msec 68 msec 88 msec
  2 3.3.3.1 116 msec 148 msec 176 msec

R5#traceroute 20.1.1.1
Type escape sequence to abort.
Tracing the route to 20.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
  1 5.5.5.2 [MPLS: Label 102 Exp 0] 40 msec 64 msec 64 msec
  2 1.1.1.2 128 msec 140 msec 152 msec





 R1#show mpls ldp binding

  lib entry: 1.0.0.0/8, rev 2
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 500
  lib entry: 2.0.0.0/8, rev 4
        local binding:  label: 99
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 501
  lib entry: 3.0.0.0/8, rev 6
        local binding:  label: 100
        remote binding: lsr: 192.168.20.1:0, label: 200
        remote binding: lsr: 192.168.50.1:0, label: 502
  lib entry: 4.0.0.0/8, rev 8
        local binding:  label: 101
        remote binding: lsr: 192.168.20.1:0, label: 201
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 5.0.0.0/8, rev 10
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 202
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 10.0.0.0/8, rev 12
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 203
        remote binding: lsr: 192.168.50.1:0, label: 503
  lib entry: 20.0.0.0/8, rev 14
        local binding:  label: 102
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 504
  lib entry: 30.0.0.0/8, rev 16
        local binding:  label: 103
        remote binding: lsr: 192.168.20.1:0, label: 204
        remote binding: lsr: 192.168.50.1:0, label: 505
  lib entry: 40.0.0.0/8, rev 18
        local binding:  label: 104
        remote binding: lsr: 192.168.20.1:0, label: 205
        remote binding: lsr: 192.168.50.1:0, label: 506
  lib entry: 50.0.0.0/8, rev 20
        local binding:  label: 105
        remote binding: lsr: 192.168.20.1:0, label: 206
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.10.0/24, rev 22
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 207
        remote binding: lsr: 192.168.50.1:0, label: 507
  lib entry: 192.168.11.0/24, rev 24
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 208
        remote binding: lsr: 192.168.50.1:0, label: 508
  lib entry: 192.168.12.0/24, rev 26
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 209
        remote binding: lsr: 192.168.50.1:0, label: 509
  lib entry: 192.168.13.0/24, rev 28
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 210
        remote binding: lsr: 192.168.50.1:0, label: 510
  lib entry: 192.168.14.0/24, rev 30
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 211
        remote binding: lsr: 192.168.50.1:0, label: 511
  lib entry: 192.168.20.0/24, rev 32
        local binding:  label: 106
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 512
  lib entry: 192.168.21.0/24, rev 34
        local binding:  label: 107
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 513
  lib entry: 192.168.22.0/24, rev 36
        local binding:  label: 108
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 514
  lib entry: 192.168.23.0/24, rev 38
        local binding:  label: 109
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 515
  lib entry: 192.168.24.0/24, rev 40
        local binding:  label: 110
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 516
  lib entry: 192.168.30.0/24, rev 42
        local binding:  label: 111
        remote binding: lsr: 192.168.20.1:0, label: 212
        remote binding: lsr: 192.168.50.1:0, label: 517
  lib entry: 192.168.31.0/24, rev 44
        local binding:  label: 112
        remote binding: lsr: 192.168.20.1:0, label: 213
        remote binding: lsr: 192.168.50.1:0, label: 518
  lib entry: 192.168.32.0/24, rev 46
        local binding:  label: 113
        remote binding: lsr: 192.168.20.1:0, label: 214
        remote binding: lsr: 192.168.50.1:0, label: 519
  lib entry: 192.168.33.0/24, rev 48
        local binding:  label: 114
        remote binding: lsr: 192.168.20.1:0, label: 215
        remote binding: lsr: 192.168.50.1:0, label: 520
  lib entry: 192.168.34.0/24, rev 50
        local binding:  label: 115
        remote binding: lsr: 192.168.20.1:0, label: 216
        remote binding: lsr: 192.168.50.1:0, label: 521
  lib entry: 192.168.40.0/24, rev 52
        local binding:  label: 116
        remote binding: lsr: 192.168.20.1:0, label: 217
        remote binding: lsr: 192.168.50.1:0, label: 522
  lib entry: 192.168.41.0/24, rev 54
        local binding:  label: 117
        remote binding: lsr: 192.168.20.1:0, label: 218
        remote binding: lsr: 192.168.50.1:0, label: 523
  lib entry: 192.168.42.0/24, rev 56
        local binding:  label: 118
        remote binding: lsr: 192.168.20.1:0, label: 219
        remote binding: lsr: 192.168.50.1:0, label: 524
  lib entry: 192.168.43.0/24, rev 58
        local binding:  label: 119
        remote binding: lsr: 192.168.20.1:0, label: 220
        remote binding: lsr: 192.168.50.1:0, label: 525
  lib entry: 192.168.44.0/24, rev 60
        local binding:  label: 120
        remote binding: lsr: 192.168.20.1:0, label: 221
        remote binding: lsr: 192.168.50.1:0, label: 526
  lib entry: 192.168.50.0/24, rev 62
        local binding:  label: 121
        remote binding: lsr: 192.168.20.1:0, label: 222
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.51.0/24, rev 64
        local binding:  label: 122
        remote binding: lsr: 192.168.20.1:0, label: 223
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.52.0/24, rev 66
        local binding:  label: 123
        remote binding: lsr: 192.168.20.1:0, label: 224
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.53.0/24, rev 68
        local binding:  label: 124
        remote binding: lsr: 192.168.20.1:0, label: 225
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.54.0/24, rev 70
        local binding:  label: 125
        remote binding: lsr: 192.168.20.1:0, label: 226
        remote binding: lsr: 192.168.50.1:0, label: imp-null






 R2#SHOW MPLS                LDP BINDING

  lib entry: 1.0.0.0/8, rev 2
        local binding:  label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 300
  lib entry: 2.0.0.0/8, rev 4
        local binding:  label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 99
        remote binding: lsr: 192.168.30.1:0, label: imp-null
  lib entry: 3.0.0.0/8, rev 6
        local binding:  label: 200
        remote binding: lsr: 192.168.10.1:0, label: 100
        remote binding: lsr: 192.168.30.1:0, label: imp-null
  lib entry: 4.0.0.0/8, rev 8
        local binding:  label: 201
        remote binding: lsr: 192.168.10.1:0, label: 101
        remote binding: lsr: 192.168.30.1:0, label: 301
  lib entry: 5.0.0.0/8, rev 10
        local binding:  label: 202
        remote binding: lsr: 192.168.10.1:0, label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 302
  lib entry: 10.0.0.0/8, rev 12
        local binding:  label: 203
        remote binding: lsr: 192.168.10.1:0, label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 303
  lib entry: 20.0.0.0/8, rev 14
        local binding:  label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 102
        remote binding: lsr: 192.168.30.1:0, label: 304
  lib entry: 30.0.0.0/8, rev 16
        local binding:  label: 204
        remote binding: lsr: 192.168.10.1:0, label: 103
        remote binding: lsr: 192.168.30.1:0, label: imp-null
  lib entry: 40.0.0.0/8, rev 18
        local binding:  label: 205
        remote binding: lsr: 192.168.10.1:0, label: 104
        remote binding: lsr: 192.168.30.1:0, label: 305
  lib entry: 50.0.0.0/8, rev 20
        local binding:  label: 206
        remote binding: lsr: 192.168.10.1:0, label: 105
        remote binding: lsr: 192.168.30.1:0, label: 306
  lib entry: 192.168.10.0/24, rev 22
        local binding:  label: 207
        remote binding: lsr: 192.168.10.1:0, label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 307
  lib entry: 192.168.11.0/24, rev 24
        local binding:  label: 208
        remote binding: lsr: 192.168.10.1:0, label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 308
  lib entry: 192.168.12.0/24, rev 26
        local binding:  label: 209
        remote binding: lsr: 192.168.10.1:0, label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 309
  lib entry: 192.168.13.0/24, rev 28
        local binding:  label: 210
        remote binding: lsr: 192.168.10.1:0, label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 310
  lib entry: 192.168.14.0/24, rev 30
        local binding:  label: 211
        remote binding: lsr: 192.168.10.1:0, label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 311
  lib entry: 192.168.20.0/24, rev 32
        local binding:  label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 106
        remote binding: lsr: 192.168.30.1:0, label: 312
  lib entry: 192.168.21.0/24, rev 34
        local binding:  label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 107
        remote binding: lsr: 192.168.30.1:0, label: 313
  lib entry: 192.168.22.0/24, rev 36
        local binding:  label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 108
        remote binding: lsr: 192.168.30.1:0, label: 314
  lib entry: 192.168.23.0/24, rev 38
        local binding:  label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 109
        remote binding: lsr: 192.168.30.1:0, label: 315
  lib entry: 192.168.24.0/24, rev 40
        local binding:  label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 110
        remote binding: lsr: 192.168.30.1:0, label: 316
  lib entry: 192.168.30.0/24, rev 42
        local binding:  label: 212
        remote binding: lsr: 192.168.10.1:0, label: 111
        remote binding: lsr: 192.168.30.1:0, label: imp-null
  lib entry: 192.168.31.0/24, rev 44
        local binding:  label: 213
        remote binding: lsr: 192.168.10.1:0, label: 112
        remote binding: lsr: 192.168.30.1:0, label: imp-null
  lib entry: 192.168.32.0/24, rev 46
        local binding:  label: 214
        remote binding: lsr: 192.168.10.1:0, label: 113
        remote binding: lsr: 192.168.30.1:0, label: imp-null
  lib entry: 192.168.33.0/24, rev 48
        local binding:  label: 215
        remote binding: lsr: 192.168.10.1:0, label: 114
        remote binding: lsr: 192.168.30.1:0, label: imp-null
  lib entry: 192.168.34.0/24, rev 50
        local binding:  label: 216
        remote binding: lsr: 192.168.10.1:0, label: 115
        remote binding: lsr: 192.168.30.1:0, label: imp-null
  lib entry: 192.168.40.0/24, rev 52
        local binding:  label: 217
        remote binding: lsr: 192.168.10.1:0, label: 116
        remote binding: lsr: 192.168.30.1:0, label: 317
  lib entry: 192.168.41.0/24, rev 54
        local binding:  label: 218
        remote binding: lsr: 192.168.10.1:0, label: 117
        remote binding: lsr: 192.168.30.1:0, label: 318
  lib entry: 192.168.42.0/24, rev 56
        local binding:  label: 219
        remote binding: lsr: 192.168.10.1:0, label: 118
        remote binding: lsr: 192.168.30.1:0, label: 319
  lib entry: 192.168.43.0/24, rev 58
        local binding:  label: 220
        remote binding: lsr: 192.168.10.1:0, label: 119
        remote binding: lsr: 192.168.30.1:0, label: 320
  lib entry: 192.168.44.0/24, rev 60
        local binding:  label: 221
        remote binding: lsr: 192.168.10.1:0, label: 120
        remote binding: lsr: 192.168.30.1:0, label: 321
  lib entry: 192.168.50.0/24, rev 62
        local binding:  label: 222
        remote binding: lsr: 192.168.10.1:0, label: 121
        remote binding: lsr: 192.168.30.1:0, label: 322
  lib entry: 192.168.51.0/24, rev 64
        local binding:  label: 223
        remote binding: lsr: 192.168.10.1:0, label: 122
        remote binding: lsr: 192.168.30.1:0, label: 323
  lib entry: 192.168.52.0/24, rev 66
        local binding:  label: 224
        remote binding: lsr: 192.168.10.1:0, label: 123
        remote binding: lsr: 192.168.30.1:0, label: 324
  lib entry: 192.168.53.0/24, rev 68
        local binding:  label: 225
        remote binding: lsr: 192.168.10.1:0, label: 124
        remote binding: lsr: 192.168.30.1:0, label: 325
  lib entry: 192.168.54.0/24, rev 70
        local binding:  label: 226
        remote binding: lsr: 192.168.10.1:0, label: 125
        remote binding: lsr: 192.168.30.1:0, label: 326


R3#show mpls ldp  binding
  lib entry: 1.0.0.0/8, rev 2
        local binding:  label: 300
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 400
  lib entry: 2.0.0.0/8, rev 4
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 401
  lib entry: 3.0.0.0/8, rev 6
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 200
        remote binding: lsr: 192.168.40.1:0, label: imp-null
  lib entry: 4.0.0.0/8, rev 8
        local binding:  label: 301
        remote binding: lsr: 192.168.20.1:0, label: 201
        remote binding: lsr: 192.168.40.1:0, label: imp-null
  lib entry: 5.0.0.0/8, rev 10
        local binding:  label: 302
        remote binding: lsr: 192.168.20.1:0, label: 202
        remote binding: lsr: 192.168.40.1:0, label: 402
  lib entry: 10.0.0.0/8, rev 12
        local binding:  label: 303
        remote binding: lsr: 192.168.20.1:0, label: 203
        remote binding: lsr: 192.168.40.1:0, label: 403
  lib entry: 20.0.0.0/8, rev 14
        local binding:  label: 304
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 404
  lib entry: 30.0.0.0/8, rev 16
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 204
        remote binding: lsr: 192.168.40.1:0, label: 405
  lib entry: 40.0.0.0/8, rev 18
        local binding:  label: 305
        remote binding: lsr: 192.168.20.1:0, label: 205
        remote binding: lsr: 192.168.40.1:0, label: imp-null
  lib entry: 50.0.0.0/8, rev 20
        local binding:  label: 306
        remote binding: lsr: 192.168.20.1:0, label: 206
        remote binding: lsr: 192.168.40.1:0, label: 406
  lib entry: 192.168.10.0/24, rev 22
        local binding:  label: 307
        remote binding: lsr: 192.168.20.1:0, label: 207
        remote binding: lsr: 192.168.40.1:0, label: 407
  lib entry: 192.168.11.0/24, rev 24
        local binding:  label: 308
        remote binding: lsr: 192.168.20.1:0, label: 208
        remote binding: lsr: 192.168.40.1:0, label: 408
  lib entry: 192.168.12.0/24, rev 26
        local binding:  label: 309
        remote binding: lsr: 192.168.20.1:0, label: 209
        remote binding: lsr: 192.168.40.1:0, label: 409
  lib entry: 192.168.13.0/24, rev 28
        local binding:  label: 310
        remote binding: lsr: 192.168.20.1:0, label: 210
        remote binding: lsr: 192.168.40.1:0, label: 410
  lib entry: 192.168.14.0/24, rev 30
        local binding:  label: 311
        remote binding: lsr: 192.168.20.1:0, label: 211
        remote binding: lsr: 192.168.40.1:0, label: 411
  lib entry: 192.168.20.0/24, rev 32
        local binding:  label: 312
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 412
  lib entry: 192.168.21.0/24, rev 34
        local binding:  label: 313
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 413
  lib entry: 192.168.22.0/24, rev 36
        local binding:  label: 314
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 414
  lib entry: 192.168.23.0/24, rev 38
        local binding:  label: 315
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 415
  lib entry: 192.168.24.0/24, rev 40
        local binding:  label: 316
        remote binding: lsr: 192.168.20.1:0, label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 416
  lib entry: 192.168.30.0/24, rev 42
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 212
        remote binding: lsr: 192.168.40.1:0, label: 417
  lib entry: 192.168.31.0/24, rev 44
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 213
        remote binding: lsr: 192.168.40.1:0, label: 418
  lib entry: 192.168.32.0/24, rev 46
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 214
        remote binding: lsr: 192.168.40.1:0, label: 419
  lib entry: 192.168.33.0/24, rev 48
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 215
        remote binding: lsr: 192.168.40.1:0, label: 420
  lib entry: 192.168.34.0/24, rev 50
        local binding:  label: imp-null
        remote binding: lsr: 192.168.20.1:0, label: 216
        remote binding: lsr: 192.168.40.1:0, label: 421
  lib entry: 192.168.40.0/24, rev 52
        local binding:  label: 317
        remote binding: lsr: 192.168.20.1:0, label: 217
        remote binding: lsr: 192.168.40.1:0, label: imp-null
  lib entry: 192.168.41.0/24, rev 54
        local binding:  label: 318
        remote binding: lsr: 192.168.20.1:0, label: 218
        remote binding: lsr: 192.168.40.1:0, label: imp-null
  lib entry: 192.168.42.0/24, rev 56
        local binding:  label: 319
        remote binding: lsr: 192.168.20.1:0, label: 219
        remote binding: lsr: 192.168.40.1:0, label: imp-null
  lib entry: 192.168.43.0/24, rev 58
        local binding:  label: 320
        remote binding: lsr: 192.168.20.1:0, label: 220
        remote binding: lsr: 192.168.40.1:0, label: imp-null
  lib entry: 192.168.44.0/24, rev 60
        local binding:  label: 321
        remote binding: lsr: 192.168.20.1:0, label: 221
        remote binding: lsr: 192.168.40.1:0, label: imp-null
  lib entry: 192.168.50.0/24, rev 62
        local binding:  label: 322
        remote binding: lsr: 192.168.20.1:0, label: 222
        remote binding: lsr: 192.168.40.1:0, label: 422
  lib entry: 192.168.51.0/24, rev 64
        local binding:  label: 323
        remote binding: lsr: 192.168.20.1:0, label: 223
        remote binding: lsr: 192.168.40.1:0, label: 423
  lib entry: 192.168.52.0/24, rev 66
        local binding:  label: 324
        remote binding: lsr: 192.168.20.1:0, label: 224
        remote binding: lsr: 192.168.40.1:0, label: 424
  lib entry: 192.168.53.0/24, rev 68
        local binding:  label: 325
        remote binding: lsr: 192.168.20.1:0, label: 225
        remote binding: lsr: 192.168.40.1:0, label: 425
  lib entry: 192.168.54.0/24, rev 70
        local binding:  label: 326
        remote binding: lsr: 192.168.20.1:0, label: 226
        remote binding: lsr: 192.168.40.1:0, label: 426


R4#show mpls ldp binding
  lib entry: 1.0.0.0/8, rev 2
        local binding:  label: 400
        remote binding: lsr: 192.168.30.1:0, label: 300
        remote binding: lsr: 192.168.50.1:0, label: 500
  lib entry: 2.0.0.0/8, rev 4
        local binding:  label: 401
        remote binding: lsr: 192.168.30.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 501
  lib entry: 3.0.0.0/8, rev 6
        local binding:  label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 502
  lib entry: 4.0.0.0/8, rev 8
        local binding:  label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 301
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 5.0.0.0/8, rev 10
        local binding:  label: 402
        remote binding: lsr: 192.168.30.1:0, label: 302
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 10.0.0.0/8, rev 12
        local binding:  label: 403
        remote binding: lsr: 192.168.30.1:0, label: 303
        remote binding: lsr: 192.168.50.1:0, label: 503
  lib entry: 20.0.0.0/8, rev 14
        local binding:  label: 404
        remote binding: lsr: 192.168.30.1:0, label: 304
        remote binding: lsr: 192.168.50.1:0, label: 504
  lib entry: 30.0.0.0/8, rev 16
        local binding:  label: 405
        remote binding: lsr: 192.168.30.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 505
  lib entry: 40.0.0.0/8, rev 18
        local binding:  label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 305
        remote binding: lsr: 192.168.50.1:0, label: 506
  lib entry: 50.0.0.0/8, rev 20
        local binding:  label: 406
        remote binding: lsr: 192.168.30.1:0, label: 306
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.10.0/24, rev 22
        local binding:  label: 407
        remote binding: lsr: 192.168.30.1:0, label: 307
        remote binding: lsr: 192.168.50.1:0, label: 507
  lib entry: 192.168.11.0/24, rev 24
        local binding:  label: 408
        remote binding: lsr: 192.168.30.1:0, label: 308
        remote binding: lsr: 192.168.50.1:0, label: 508
  lib entry: 192.168.12.0/24, rev 26
        local binding:  label: 409
        remote binding: lsr: 192.168.30.1:0, label: 309
        remote binding: lsr: 192.168.50.1:0, label: 509
  lib entry: 192.168.13.0/24, rev 28
        local binding:  label: 410
        remote binding: lsr: 192.168.30.1:0, label: 310
        remote binding: lsr: 192.168.50.1:0, label: 510
  lib entry: 192.168.14.0/24, rev 30
        local binding:  label: 411
        remote binding: lsr: 192.168.30.1:0, label: 311
        remote binding: lsr: 192.168.50.1:0, label: 511
  lib entry: 192.168.20.0/24, rev 32
        local binding:  label: 412
        remote binding: lsr: 192.168.30.1:0, label: 312
        remote binding: lsr: 192.168.50.1:0, label: 512
  lib entry: 192.168.21.0/24, rev 34
        local binding:  label: 413
        remote binding: lsr: 192.168.30.1:0, label: 313
        remote binding: lsr: 192.168.50.1:0, label: 513
  lib entry: 192.168.22.0/24, rev 36
        local binding:  label: 414
        remote binding: lsr: 192.168.30.1:0, label: 314
        remote binding: lsr: 192.168.50.1:0, label: 514
  lib entry: 192.168.23.0/24, rev 38
        local binding:  label: 415
        remote binding: lsr: 192.168.30.1:0, label: 315
        remote binding: lsr: 192.168.50.1:0, label: 515
  lib entry: 192.168.24.0/24, rev 40
        local binding:  label: 416
        remote binding: lsr: 192.168.30.1:0, label: 316
        remote binding: lsr: 192.168.50.1:0, label: 516
  lib entry: 192.168.30.0/24, rev 42
        local binding:  label: 417
        remote binding: lsr: 192.168.30.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 517
  lib entry: 192.168.31.0/24, rev 44
        local binding:  label: 418
        remote binding: lsr: 192.168.30.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 518
  lib entry: 192.168.32.0/24, rev 46
        local binding:  label: 419
        remote binding: lsr: 192.168.30.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 519
  lib entry: 192.168.33.0/24, rev 48
        local binding:  label: 420
        remote binding: lsr: 192.168.30.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 520
  lib entry: 192.168.34.0/24, rev 50
        local binding:  label: 421
        remote binding: lsr: 192.168.30.1:0, label: imp-null
        remote binding: lsr: 192.168.50.1:0, label: 521
  lib entry: 192.168.40.0/24, rev 52
        local binding:  label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 317
        remote binding: lsr: 192.168.50.1:0, label: 522
  lib entry: 192.168.41.0/24, rev 54
        local binding:  label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 318
        remote binding: lsr: 192.168.50.1:0, label: 523
  lib entry: 192.168.42.0/24, rev 56
        local binding:  label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 319
        remote binding: lsr: 192.168.50.1:0, label: 524
  lib entry: 192.168.43.0/24, rev 58
        local binding:  label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 320
        remote binding: lsr: 192.168.50.1:0, label: 525
  lib entry: 192.168.44.0/24, rev 60
        local binding:  label: imp-null
        remote binding: lsr: 192.168.30.1:0, label: 321
        remote binding: lsr: 192.168.50.1:0, label: 526
  lib entry: 192.168.50.0/24, rev 62
        local binding:  label: 422
        remote binding: lsr: 192.168.30.1:0, label: 322
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.51.0/24, rev 64
        local binding:  label: 423
        remote binding: lsr: 192.168.30.1:0, label: 323
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.52.0/24, rev 66
        local binding:  label: 424
        remote binding: lsr: 192.168.30.1:0, label: 324
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.53.0/24, rev 68
        local binding:  label: 425
        remote binding: lsr: 192.168.30.1:0, label: 325
        remote binding: lsr: 192.168.50.1:0, label: imp-null
  lib entry: 192.168.54.0/24, rev 70
        local binding:  label: 426
        remote binding: lsr: 192.168.30.1:0, label: 326
        remote binding: lsr: 192.168.50.1:0, label: imp-null
R5#show mpls ldp binding
  lib entry: 1.0.0.0/8, rev 2
        local binding:  label: 500
        remote binding: lsr: 192.168.40.1:0, label: 400
        remote binding: lsr: 192.168.10.1:0, label: imp-null
  lib entry: 2.0.0.0/8, rev 4
        local binding:  label: 501
        remote binding: lsr: 192.168.40.1:0, label: 401
        remote binding: lsr: 192.168.10.1:0, label: 99
  lib entry: 3.0.0.0/8, rev 6
        local binding:  label: 502
        remote binding: lsr: 192.168.40.1:0, label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 100
  lib entry: 4.0.0.0/8, rev 8
        local binding:  label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 101
  lib entry: 5.0.0.0/8, rev 10
        local binding:  label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 402
        remote binding: lsr: 192.168.10.1:0, label: imp-null
  lib entry: 10.0.0.0/8, rev 12
        local binding:  label: 503
        remote binding: lsr: 192.168.40.1:0, label: 403
        remote binding: lsr: 192.168.10.1:0, label: imp-null
  lib entry: 20.0.0.0/8, rev 14
        local binding:  label: 504
        remote binding: lsr: 192.168.40.1:0, label: 404
        remote binding: lsr: 192.168.10.1:0, label: 102
  lib entry: 30.0.0.0/8, rev 16
        local binding:  label: 505
        remote binding: lsr: 192.168.40.1:0, label: 405
        remote binding: lsr: 192.168.10.1:0, label: 103
  lib entry: 40.0.0.0/8, rev 18
        local binding:  label: 506
        remote binding: lsr: 192.168.40.1:0, label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 104
  lib entry: 50.0.0.0/8, rev 20
        local binding:  label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 406
        remote binding: lsr: 192.168.10.1:0, label: 105
  lib entry: 192.168.10.0/24, rev 22
        local binding:  label: 507
        remote binding: lsr: 192.168.40.1:0, label: 407
        remote binding: lsr: 192.168.10.1:0, label: imp-null
  lib entry: 192.168.11.0/24, rev 24
        local binding:  label: 508
        remote binding: lsr: 192.168.40.1:0, label: 408
        remote binding: lsr: 192.168.10.1:0, label: imp-null
  lib entry: 192.168.12.0/24, rev 26
        local binding:  label: 509
        remote binding: lsr: 192.168.40.1:0, label: 409
        remote binding: lsr: 192.168.10.1:0, label: imp-null
  lib entry: 192.168.13.0/24, rev 28
        local binding:  label: 510
        remote binding: lsr: 192.168.40.1:0, label: 410
        remote binding: lsr: 192.168.10.1:0, label: imp-null
  lib entry: 192.168.14.0/24, rev 30
        local binding:  label: 511
        remote binding: lsr: 192.168.40.1:0, label: 411
        remote binding: lsr: 192.168.10.1:0, label: imp-null
  lib entry: 192.168.20.0/24, rev 32
        local binding:  label: 512
        remote binding: lsr: 192.168.40.1:0, label: 412
        remote binding: lsr: 192.168.10.1:0, label: 106
  lib entry: 192.168.21.0/24, rev 34
        local binding:  label: 513
        remote binding: lsr: 192.168.40.1:0, label: 413
        remote binding: lsr: 192.168.10.1:0, label: 107
  lib entry: 192.168.22.0/24, rev 36
        local binding:  label: 514
        remote binding: lsr: 192.168.40.1:0, label: 414
        remote binding: lsr: 192.168.10.1:0, label: 108
  lib entry: 192.168.23.0/24, rev 38
        local binding:  label: 515
        remote binding: lsr: 192.168.40.1:0, label: 415
        remote binding: lsr: 192.168.10.1:0, label: 109
  lib entry: 192.168.24.0/24, rev 40
        local binding:  label: 516
        remote binding: lsr: 192.168.40.1:0, label: 416
        remote binding: lsr: 192.168.10.1:0, label: 110
  lib entry: 192.168.30.0/24, rev 42
        local binding:  label: 517
        remote binding: lsr: 192.168.40.1:0, label: 417
        remote binding: lsr: 192.168.10.1:0, label: 111
  lib entry: 192.168.31.0/24, rev 44
        local binding:  label: 518
        remote binding: lsr: 192.168.40.1:0, label: 418
        remote binding: lsr: 192.168.10.1:0, label: 112
  lib entry: 192.168.32.0/24, rev 46
        local binding:  label: 519
        remote binding: lsr: 192.168.40.1:0, label: 419
        remote binding: lsr: 192.168.10.1:0, label: 113
  lib entry: 192.168.33.0/24, rev 48
        local binding:  label: 520
        remote binding: lsr: 192.168.40.1:0, label: 420
        remote binding: lsr: 192.168.10.1:0, label: 114
  lib entry: 192.168.34.0/24, rev 50
        local binding:  label: 521
        remote binding: lsr: 192.168.40.1:0, label: 421
        remote binding: lsr: 192.168.10.1:0, label: 115
  lib entry: 192.168.40.0/24, rev 52
        local binding:  label: 522
        remote binding: lsr: 192.168.40.1:0, label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 116
  lib entry: 192.168.41.0/24, rev 54
        local binding:  label: 523
        remote binding: lsr: 192.168.40.1:0, label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 117
  lib entry: 192.168.42.0/24, rev 56
        local binding:  label: 524
        remote binding: lsr: 192.168.40.1:0, label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 118
  lib entry: 192.168.43.0/24, rev 58
        local binding:  label: 525
        remote binding: lsr: 192.168.40.1:0, label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 119
  lib entry: 192.168.44.0/24, rev 60
        local binding:  label: 526
        remote binding: lsr: 192.168.40.1:0, label: imp-null
        remote binding: lsr: 192.168.10.1:0, label: 120
  lib entry: 192.168.50.0/24, rev 62
        local binding:  label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 422
        remote binding: lsr: 192.168.10.1:0, label: 121
  lib entry: 192.168.51.0/24, rev 64
        local binding:  label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 423
        remote binding: lsr: 192.168.10.1:0, label: 122
  lib entry: 192.168.52.0/24, rev 66
        local binding:  label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 424
        remote binding: lsr: 192.168.10.1:0, label: 123
  lib entry: 192.168.53.0/24, rev 68
        local binding:  label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 425
        remote binding: lsr: 192.168.10.1:0, label: 124
  lib entry: 192.168.54.0/24, rev 70
        local binding:  label: imp-null
        remote binding: lsr: 192.168.40.1:0, label: 426
        remote binding: lsr: 192.168.10.1:0, label: 125



 here you can see the labels which assigned. 
 for more interesting labs please visit CCIE Labs. 












Internetworks

Author & Editor

I am CCIE Technical Instructor/Network consultant. i am having experience of ranging from operating and maintaining PCs and peripherals to network control programs for multi-faceted data communication networks in LAN,MAN, and WAN environments.

0 comments: